Server gone to 8 TPS, all of a sudden

Discussion in 'Performance Tweaking' started by CraftyFoxe, Jun 29, 2020.

  1. The Foxshot plugins are unoptimized.
     
  2. Remove geo IP btw (its not needed for you)
     
  3. What's a foxshot plugin
     
  4. Foxshot plox or something
     
  5. Hmm that's a world not a plugin
     
  6. What's your plot plugin?
     
  7. I use Plotsquared V5
     
  8. delete worlds so there will be no saving of worlds :unsure:
     
  9. [​IMG] one world says 1k chunks are loaded even though I'm the only one on
     
  10. Assuming you're in the world FoxshotPlot, it seems like your server is keeping the spawn loaded. Try setting
    keep-spawn-loaded to false in your paper.yml (which solved quite a bit of issues for me in the past so it might work for you either)

    EDIT: you might want to check out this optimization guide if you haven't done so already: https://www.spigotmc.org/threads/guide-server-optimization.283181/
     
  11. I don't see anything bad in the timings report. What kind of hosting is this (home, shared, VPS, dedicated)? What kind of processor, if you know?
     
  12. I fixed the problem by changing the default world in server.properties to another world instead of world and after I restart, it was fine back to 20 TPS