Server is lagging too much with just 3 people

Discussion in 'Performance Tweaking' started by kyrax80, Mar 15, 2020.

  1. Hello,


    I've made a Minecraft server using version 1.15.2 to play with my friends. We're just 3 and whith just 2 or even 1 it's lagging sometimes. I am also getting this message: Can't keep up! Is the server overloaded? Running 8539ms or 170 ticks behind


    I've tried with these 2 servers. Which hardware do I exactly need to make it run smothly?


    - VPS I've tried:


    VPS 1

    KVM OpenStack

    1 vCore(s)
    Desde 2 GHz
    2 GB RAM
    20 GB SSD
    Local RAID

    VPS 2

    KVM OpenStack
    SLA 99,99 %
    1 vCore(s)
    Desde 2 GHz
    6 GB RAM
    25 GB


    - Mods that I'm using
    - DungeonCrawl-1.15.2-1.6.3
    - extragolems-10.0.0-beta
    - globalxp-1.15.2-v1.4.11
    - goblintraders-1.2.0-1.15.2
    - good-nights-sleep-1.15.2-1.0.1
    - Hwyla-forge-1.10.7-B71_1.15.1
    - jei-1.15.2-6.0.0.2
    - mcw-bridges-1.0.3-mc1.15.2
    - mining-helmet-1.15.2-1.0.6
    - NaturesCompass-1.15.2-1.8.4
    - nethercraft-1.15.2-1.0.6
    - OresAboveDiamonds+1.15+v3.2
    - Overloaded-Armor-Bar-Mod-1.15
    - SBM-Merpig-1.15.1-0.0.1
    - simplylight-1.15.2-0.9.0
    - speedyladders-1.15.2-1
    - tombstone-4.2.0-1.15.1
    - Xaeros_Minimap_20.3.1.1_Forge_1.15.2

    - Command used to run the server
    java -jar -server -Xms524M -XX:+UseG1GC forge-1.15.2-31.1.18.jar nogui

    Thank you in advance!
     
    • Funny Funny x 1
  2. You are using mods and a resource heavy game on a small / weak VPS. Not to mention 512 MB of ram.
     
  3. Okay, I found the 2 mods that were giving me problems:

    1. mining-helmet-1.15.2-1.0.6. This seems to lag just by using it, must be because of continously changing shadows or something like that. And to top it off, zombies can also wear it.
    2. SBM-Merpig-1.15.1-0.0.1. Near of where I was lagging, literally like 200 of these mobs spawned,

    Just installed those and 0 problems now
     
  4. I don't think 2GB of RAM is enough to run heavy mods that do a lot of things

    Pretty sure this is your problem.
     
  5. Add more ram 524M is less then a GB of Ram. Try setting it to 2048M for 2gb. or 4096M which is 4GB.