Solved Server joinable with all 1.9 versions?

Discussion in 'Spigot Help' started by justinn, May 31, 2016.

  1. Hello Everyone,

    Is it possible to make a 1.9.4 server which will be joinable for 1.9, 1.9.2, 1.9.3 and 1.9.4?
    Is this possible because players of my server are asking for it and I can't find it anywhere :(

    Hope that someone can help me!!

    Best Regards ggamehdtv
     
  2. They use different protocols I think. So it is possible. But you would need a protocol hack for all 1.9 versions. Don't know if that exists
     
  3. You'll probably need to ask someone to make a protocol hack for you
     
  4. @justinn The newer versions of ViaVersion let 1.9.1, 1.9.2, 1.9.3 and 1.9.4 clients join 1.9, which is what you asked for. Not only that, but with 1.9.4, all lower 1.9 versions can also join.

    @Mylescomputer is the developer and can confirm.
     
  5. FormallyMyles

    Supporter

    Correct
     
  6. Jeez, you respond fast :D
     
    • Funny Funny x 1
  7. It does let 1.9.x client let the server join but it is build on a 1.8 server that's the problem. So I don't have the 1.9 stuff when using viaversion and I need the 1.9 stuff
     
  8. Wait, I'm sorry, what version is your server running and what version(s) do you want to be able to join?

    I'm a bit confused by your wording @justinn
     
  9. I have a 1.9.4 server right now. But my players are asking if I can change it so all 1.9.x clients can join. because they need to switch everytime now.
     
  10. Run your server on Spigot 1.9.2 and use the ViaVersion plugin. This will allow all versions of 1.9 to join.
     
  11. this is not the way that viaversion is working.

    Viaversion must be installed on a 1.8 server and will allow 1.8.x and 1.9.x clients.

    I only want 1.9.x on a 1.9.4 server
     
  12. FormallyMyles

    Supporter

    No

    ViaVersion supports 1.9.x on ANY 1.9.x spigot build.

    Though 1.8 client only works on 1.8 server.
     
  13. uhm nevermind found it :p
    upload_2016-5-31_23-45-57.png
     
  14. Yes, ViaVersion if installed on a 1.9.4 will accept only 1.9.x not 1.8.x
     
  15. That's just because 1.8 doesn't know how to handle the offhand stuff, as well as shields and new mobs.