Server Joining Issues

Discussion in 'Minecraft Discussion' started by Vanillezucker, Feb 8, 2017.

  1. Hi, I'm running into a problem. (I don't know where to post it so I'm gonna post it here. Moderators, please move if I'm wrong)

    Every time I'm trying to join a server using both Optifine and a vanilla client, I'm getting kicked (some weird message in another language, saying the connection was closed by the remote host), and if I'm getting through that, I'm kicked for the same reason once I teleport into another world. It is happening on every server not hosted on my local device on any version (I tested 1.8.9, 1.9, 1.10.2, 1.11.2 on both ViaVersion and single-version servers).

    Code (Text):
    [Client thread/FATAL]: Error executing task
    java.util.concurrent.ExecutionException: java.lang.NullPointerException
       at java.util.concurrent.FutureTask.report(FutureTask.java:122) ~[?:1.8.0_25]
       at java.util.concurrent.FutureTask.get(FutureTask.java:192) ~[?:1.8.0_25]
       at h.a(SourceFile:46) [1.10.2.jar:?]
       at bcx.av(SourceFile:960) [1.10.2.jar:?]
       at bcx.a(SourceFile:396) [1.10.2.jar:?]
       at net.minecraft.client.main.Main.main(SourceFile:124) [1.10.2.jar:?]
    Caused by: java.lang.NullPointerException
       at bch.d(SourceFile:231) ~[1.10.2.jar:?]
       at bll.a(SourceFile:1585) ~[1.10.2.jar:?]
       at hx.a(SourceFile:117) ~[1.10.2.jar:?]
       at hx.a(SourceFile:13) ~[1.10.2.jar:?]
       at fl$1.run(SourceFile:13) ~[1.10.2.jar:?]
       at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_25]
       at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_25]
       at h.a(SourceFile:45) ~[1.10.2.jar:?]
       ... 3 more
    (The errors look equal for each version, except the minecraft version within the error, obviously)
    I hope someone can help me. I already tried updating and reinstalling Java (that 1.8.0_25 are the libraries minecraft downloaded), completely reinstalling Minecraft, disabling my firewall, running 3 different anti virus scanners (Avast, Avira and ADWCleaner). Got any idea? I can play every game in multiplayer but minecraft.
     
  2. I found out it's an issue with a router setup - I have no clue which one though.

    I edited the filter function and the NAT settings with no proper result.
     
  3. Is there any chance on that, without resetting my router?
     
  4. It's odd that I'm the only person running into problems not solvable. (In the past, I got rid of some of that problems) Hilarious.

    By the way, I forgot to mention the obvious fact that I have already restarted my router. (not the same as resetting to factory settings!)

    (I also have to use Wi-Fi.)
     
  5. I did a lot of things, but I didn't know what fixed it.
    It works again.
     
    • Funny Funny x 1
  6. Try to reinstall Minecraft
     
  7. owh okay lol, could be a bug maybe
     
  8. Are you serious???

    #1 I said I fixed it somehow
    #2:
     
  9. This is supposed to be in Spigot Help if that is what you wanted to know
     
  10. It had nothing to do with Spigot?