Solved Server keeps crashing - help!

Discussion in 'Spigot Help' started by WavejumpGames, Jul 17, 2017.

  1. I've been trying for the past hour to get my server to stop crashing and I just can't figure out why it is crashing. I have updated the server's version of Spigot. The server is on 1.12 and was running fine all day until somebody pressed a button which triggered the server's crashing. I've tried disabling a couple of plugins which has done nothing, running timings (which has not worked because the server crashes), and deleting the playercache. The server crashes a couple of seconds after players join but when players join a very large lag spike occurs. I've tried killing every entity and that doesn't work either. The server runs fine until players join - then, the players get timed out and the server crashes. Please let me know what I can do to fix this - resetting the world isn't really an option for me.
    Crash report: https://hastebin.com/uxojogamic.rb
    Server log: https://hastebin.com/ugagiziliq.md
     
    #1 WavejumpGames, Jul 17, 2017
    Last edited: Jul 17, 2017
  2. As one of your errors said, some of your plugins are not supported to the Minecraft version you are using right now.
     
  3. I've had these same plugins for at least a month now without any issues...
     
  4. Are you sure all of the plugins are up to date? Have you tried to disable GriefPrevetion?
     
  5. As I mentioned above, I have tried disabling GriefPrevention but it hasn't done anything. My plugins should all be up to date but as I'm writing this I'm running buildtools to get a new 1.12 spigot jar.
     
  6. I just updated the server to the latest build and nothing changed. Could it possibly be a corrupted chunk?
     
  7. redownload the latest multiverse and try the server then
     
  8. Update: Unfortunately, disabling all plugins made no difference to the server's crash - I will post a crash log here soon.
     
  9. Yep - That's the survival world.
    I'm trying to download and run it locally without a server right now.
     
  10. Have you upgraded your server to 1.12 lately? And just kept the old files of the previous version?
     
  11. The server was updated to 1.12 as soon as the first build came out. I had to remove a bunch of plugins in order to get it to work but I am using the same world that I used in 1.11
     
  12. Try re-creating the world in 1.12? Maybe that will work out? So just delete your old world (back-up first) and then let it auto create with the server it self.
     
  13. I'll try running the server with a new world but switching to a new world really isn't an option here. I'm also going to run regionfixer over it to see if there is a corrupted area.
    Update: A new world did work but I need to get the old world to work.
    Update 2: swTest still crashed in singleplayer - I'm running region-fixer.
     
    #17 WavejumpGames, Jul 17, 2017
    Last edited: Jul 17, 2017
  14. Nothing was able to fix it in the end - I had to restore from an old backup.
     
  15. I have been having trouble with my 1.12.2 server too. Every time I click the shortcut to get it running, it opens for 1 second then shuts off. I don't get why, it was working fine just a few days ago. Please help and give me some answers as to why.