Server Lag

Discussion in 'Server & Community Management' started by Baifish, Jun 4, 2017.

Thread Status:
Not open for further replies.
  1. So I own a dedicated server (Specs listed below) and yesterday I hosted a UHC with 10 players. I used UHC Blox on 1.11 Vanilla and my server seemed to lag. I had 6GB of ram dedicated so it wasn't that. I pregenerated the chunks. Any help on why it was lagging? Thanks

    Specs:
    CPU: E5-1620
    RAM: 16GB DDR3
    Disk: 1TB HDD
    Minecraft Version: Vanilla 1.11
    Log Screenshot (It was like this constantly):[​IMG]
     
    #1 Baifish, Jun 4, 2017
    Last edited: Jun 4, 2017
    • Funny Funny x 1
  2. Post your server timings and/or plugin list along with server version and other info if you want people to help you fix lag fam, not alot we can tell you with just what you posted
     
  3. Maybe the network connection of your server isn't very good?
     
  4. I added some more information :)
     
  5. The server has 1GB up and down fine
     
  6. Probably a problem with a plugin.
     
  7. I was running vanilla
     
  8. Timings please. If it's vanilla. someone is probably running a million hoppers or something
     
  9. It was a UHC Command Block contraption. I worked when we went to 6 players.

    And what do you mean by timings please?
     
  10. Timings is a Bukkit/Spigot command that records timings for both Minecraft and plugin events. This lets you see what is slowing down your server the most. Since you are in vanilla you will probably want to create a copy of your server with Spigot 1.11 and then run timings from that server.
     
  11. Alright thanks! I'll try to host another UHC tonight and I'll post the timings after
     
  12. Here are the timings from spigot. These are for another server I run (on the same machine). https://pastebin.com/FXgutmGr
     
  13. UHC servers take a lot of memory and a lot of dedicated machines can't handle them because of a world generation you need pre generated world , mcedit or plugin that generates world in specified area for example worldborder
     
  14. I pregenerated btw but i think i know the problem
     
  15. The problem was is that I was a bit of a spoon and I for some reason had the render distance set to 16. Which is really not a great idea. I changed it to 8 and seems to be working fine! :)

    Apologies for being a spoon! :p
     
Thread Status:
Not open for further replies.