Server Load nearly 100%

Discussion in 'Performance Tweaking' started by Laynoooor, May 28, 2016.

  1. My server is running newest spigot 1.9.4 version, with 2GB RAM for server. Using HDD(very bad I/O performance)
    Server Load is very high.
    Using "top" command
    [​IMG]

    My Timings: https://timings.spigotmc.org/?url=16759120

    Is there any way to solve this problem?
    Thanks!
     
    #1 Laynoooor, May 28, 2016
    Last edited: May 28, 2016
  2. Have you tried editing your server configs according to timing's tips (Click "Learn more").

    Full Server Tick is the best representation of your servers performance, in the Pct Tick Column. If this value hits 100%, then your server is unable to keep up and will begin losing TPS. There is no magical solution to improving Full Server Tick, it is merely provided to see a better summary of your overall server performance and you can improve it by improving other timings on your server such as entities and plugins.

    Spigot introduces a major feature called Entity Activation Range that lets you specify ranges away from a player that an entity will enter "inactive" state, meaning it will slow down its activity. Any inactive entity will reduce its performance cost by up to 95%! This can be a major savings in terms of performance on servers that have lots of entities.

    With Entity Activation Range, it is no longer necessary to use ClearLagg to wipe out every entity on a schedule, as you can instead set the Misc setting for your world to be lower, such as 4. This will make items on the ground not cause you any lag!

    Additionally, setting the animals setting lower to such as 12, will greatly reduce impact from animal farms. And finally, you can safely lower monsters to about 24 without any real noticable impact.

    Lowering these settings will lower the "Active Entities" summary at the top of this report, and will give a much better TPS.

    Maybe a huge amount of entities pooling in one specific region?
     
  3. Yeah, I've changed my configs already.

    Maybe a huge amount of entities pooling in one specific region?

    I've set the entities limits in 1x1 area to 10. Still to much?
     
  4. electronicboy

    IRC Staff

    0.22% 696.73% 4.88 s 348.37 ms 0.0 0.0k World Save

    Looks like bad disk I/O and potentially furniturelib on top of the disk I/O issues.
    Increase the time between automatic world saves inside bukkit.yml (or disable it completely and schedule saves using a plugin that will allow you to run commands periodically)
     
  5. Indeed the OP should consider upgrading some/all of the storage to run on SSDs instead. That will mitigate high CPU usage from I/O related tasks.