Server not loading

Discussion in 'Spigot Help' started by Wierch, Dec 26, 2017.

  1. So yesterday i downloaded spigot 1.8.8 server jar and ran it with start.bat
    Code (Text):
    java -Xms1024M -Xmx1024M -jar spigot.jar -o true
    PAUSE
    Everything worked fine until today. I am starting start.bat and it prints this to console:
    [18:20:54] [Server thread/INFO]: Starting minecraft server version 1.8.8
    [18:20:54] [Server thread/INFO]: Loading properties
    [18:20:55] [Server thread/INFO]: Default game type: SURVIVAL
    [18:20:55] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-21fe707-e1ebe52 (MC: 1.8.8) (Implementing API version 1.8.8-R0.1-SNAPSHOT)
    [18:20:55] [Server thread/INFO]: Debug logging is disabled
    [18:20:55] [Server thread/INFO]: Using 4 threads for Netty based IO
    [18:20:55] [Server thread/INFO]: Server Ping Player Sample Count: 12
    [18:20:55] [Server thread/INFO]: Generating keypair
    [18:20:55] [Server thread/INFO]: Starting Minecraft server on localhost:25566
    [18:20:55] [Server thread/INFO]: Using default channel type
    Any help?
     
  2. Try to use this instead:

    Code (Text):
    java -Xms6G -Xmx6G -jar spigot.jar
    pause
    Change the amount of RAM so it works for you PC. Let me know if it helped.

    Also, your port is 25566? Default port is 25565.
     
  3. still doesn't work :/ for some reason the cmd wont close instantly, i have to go to task manager to close it.
     
  4. If you've tried the things i've said, may you paste your server.properties into here? thanks.
     
  5. As mentioned above, maybe you post your server.properties? And the name of the server, not the .bat file.
     
  6. #Minecraft server properties
    #Tue Dec 26 19:25:03 EET 2017
    generator-settings=
    op-permission-level=4
    resource-pack-hash=
    allow-nether=true
    level-name=world
    enable-query=false
    allow-flight=false
    announce-player-achievements=true
    server-port=25565
    max-world-size=29999984
    level-type=DEFAULT
    enable-rcon=false
    force-gamemode=false
    level-seed=
    server-ip=localhost
    network-compression-threshold=256
    max-build-height=256
    spawn-npcs=true
    white-list=false
    spawn-animals=true
    snooper-enabled=true
    hardcore=false
    online-mode=false
    resource-pack=
    pvp=true
    difficulty=1
    enable-command-block=false
    player-idle-timeout=0
    gamemode=0
    max-players=1
    spawn-monsters=true
    view-distance=10
    generate-structures=true
    spawn-protection=16
    motd=A Minecraft Server
     
  7. Name? I dont think changed server name will affect how server works
     
  8. Okay, remove the ip from your server, make the field completely blank and try again.
     
  9. same thing, it prints *:25565 in cmd as the ip now
     
  10. Remove localhost from IP since localhost has nothing to do with it.
    You can leave that part blank or input your IPV4 address there, personally, I dont't put in anything.
     
  11. *:25565 means it's ALL ip running through the port 25565
     
  12. That's normal, does that for me aswell. Localhost as the IP will work, but thought to see incase it was that.

    I also noticed there are some things with your server.properties that aren't defaulty set. You have online-mode to false and max-players to 1?
    Try and remove your server.properties and reload the server from that.
     
  13. the .jar / the server file u downloaded, may I know the name of it? Because this can affect what you have put in the .bat file.
     
  14. So I downloaded spigot 1.8.8 spigot jar server file and renamed it to spigot.jar, in the .bat i inserted this name
     
  15. java -Xms2G -Xmx2G -jar spigot.jar
    pause

    this is how my .bat code looks now
     
  16. Code (Text):
    java -Xmx1024M -jar spigot.jar -o true
    PAUSE
    try this in the .bat
     
    • Winner Winner x 1
  17. Thanks! It runs now, I'm hoping this will work forever.
     
  18. You are welcome :D
     
  19. Hmm, if you've reset the server.properties, try re-doing the whole process again.
    Here are pictures of my localhost server, see if you notice anything you dont have, ignore things such as the resource pack and plugins:


    Edit: I see it works now, good job :)