1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Server stoping by self

Discussion in 'Bugs & Feature Requests' started by siemaeniu500, Dec 18, 2013.

  1. When i get version 1.7.2 my server started "stoping" byself.
    I don't know what causing that. But in every few minutes after server start, server automaticly get stop.

    Build: #1202

    Plugin list:
    Code (Text):
    MultiWorld, TimeSpawner, WorldBorder, GroupManager, CleanChat, Vault, cTablist, QuickTrade, SurvivalGames, SQLibrary, Permissions, OpenInv, CombatTagInstakill, Citizens, HideStream, SimpleBackup, WorldEdit, Rlb, ExpLevelGive, Skript, TagAPI, MaxBans, AntiBotUltra, HealthBar, BarAPI, Quester, WorldGuard, DispenserRefill, HeadDrops, SignColours, iConomy, CoreProtect, LimitedCreative, ButtonWarp, CrazyCore, Essentials, MagicCarpet, ButtonWarpRandom, CrazyLogin, UltraTrader, TreasureChest, CraftBook, EssentialsChat, mcMMO, BossBarMessage, EssentialsSpawn, NameTags, VanishNoPacket, CrazyLogin_FactionProtection, RedeemMCMMO, Factions, ObsidianDestroyer, CompatNoCheatPlus, BattleTags, NoCheatPlus, PayInItemsForGuild, Info Board
    Example log:
    Code (Text):
    [13:35:10] [Craft Scheduler Thread - 36/WARN]: [SurvivalGames] [SurvivalGames] could not check for updates.
    [13:35:11] [Server thread/INFO]: siemaeniu500 issued server command: /login xxx
    [13:35:16] [Server thread/INFO]: siemaeniu500 issued server command: /tp azoz
    [13:35:19] [Server thread/INFO]: siemaeniu500 issued server command: /v
    [13:35:19] [Server thread/INFO]: [VanishNoPacket] siemaeniu500 reappeared.
    [13:35:25] [Server thread/INFO]: siemaeniu500: /chat wlacz
    [13:35:25] [Server thread/INFO]: Azoz_Kh lost connection: Disconnected
    [13:35:26] [Server thread/INFO]: **kokos [Wlasciciel] siemaeniu500: siema
    [13:35:29] [Server thread/INFO]: Stopping server
    [13:35:29] [Server thread/INFO]: [Info Board] Disabling Info Board v0.1.4
    [13:35:29] [Server thread/INFO]: [PayInItemsForGuild] Disabling PayInItemsForGuild v1.0
    [13:35:29] [Server thread/INFO]: [NoCheatPlus] Disabling NoCheatPlus v3.10.7-BETA-sMD5NET-b651
    [13:35:29] [Server thread/INFO]: [NoCheatPlus] Removed hook: mcMMO(cncp) [2.3].
    [13:35:29] [Server thread/INFO]: [NoCheatPlus] Removed hook: Citizens2(cncp) [2.0].
    [13:35:29] [Server thread/INFO]: [CompatNoCheatPlus] [cncp] Removed 2 registered hooks from NoCheatPlus.
     
  2. Jigsaw

    Supporter


  3. I probably found plugins which causing that:

    It is Mutliverse Core and Multiverse Portals.
    I removed those plugins, and now there is no problems.

    My moderators told my that, when i updated those plugins, server started crash byself.
     
  4. Jigsaw

    Supporter

    You completely removed them? Or you are using different versions? I have those two plugs, but I can't really remove them completely unless I find an alternative.
     

  5. In 99% this plugins causing that, i removed that plugins, and after that there are no crashes.
     
  6. Jigsaw

    Supporter

    Okay, I will keep that in mind. What plugin are you using for multiple worlds?
     
  7. Have you updated them to their newest versions? (Dev)
    My 1.7.4 test server is at 7 hours uptime. Would be more but reset it a few times.
    [​IMG]
    http://ci.onarandombox.com/
     
  8. Jigsaw

    Supporter

    I will update to the newest version. Thanks for the info. :)
     
  9. Strange, I'm using the 1.4.5 (bukkitdev) Multiverse core+netherportals+portals on my server without issue. Although with Spigot build #1187. This might be an issue with the latest builds.
     
  10. Jigsaw

    Supporter

    I downgraded to 1187 a few hours ago thinking it might be an issue with new builds. The server just crashed again after a few hours of uptime. I'm not sure which version of MV I'm using. I know that it is old, though.

    siemaeniu500, which build of Multiverse were you using?
     

  11. I deleted mutliverse, now i am using " Multi World "
     
  12. Jigsaw

    Supporter

    Thanks for all the information. How long have you gone without a crash as of now?
     
  13. About day
     
    • Like Like x 1
  14. Yuck.


    16 hours uptime on the test server now. In case it helps, here are the versions I am using.
    [​IMG]
    MV-C: [Multiverse-Core] Loading Multiverse-Core v2.5-b677
    MV-I: [Multiverse-Inventories] Loading Multiverse-Inventories v2.5-b357
     
    • Like Like x 1
  15. Jigsaw

    Supporter

    It does help. :) I will give that a try before I switch to something other than Multiverse.

    Were there active players on the server?
     
    • Optimistic Optimistic x 1

  16. Besides the odd staff member testing things to make sure nothing will explode with our current setup and 1.7, no sorry. It is after all a test server :D
     
  17. Jigsaw

    Supporter

    I'm guessing the issue has to do with players actually interacting and doing things on the server. The times vary depending on how active the server is, but the crash always looks the same or at least very similar. Either way, I will give the dev builds a try.
     
  18. If you do feel it is MV causing it, it may be a good Idea to enable it's debug mode. That way you may catch something a little more then the server shutting down.
     
  19. md_5

    Administrator Developer

    If you run a panel such as multicraft its probably that. Also check your syslog to make sure the OOM killer isn't killing it.
     

  20. If it was OOM, it wouldn't show the plugins shutting down ect as the java process is just killed, not told to run the stop command. (Unless I am incorrect when it comes to OOM and minecraft)