1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Crash server stopped responding at restart

Discussion in 'Bugs & Feature Requests' started by adopted54, May 2, 2015.

  1. Hi,

    - nothing in Minecraft crash-report folder
    - scheduled restart was just completing
    - curious messages about a player being authenticated right before the Spigot crash dump (I included this in the pastebin)

    Spigot report here: http://pastebin.com/80rVG5ws
     
  2. McMMO is the problem. Try updating it
     
    • Useful Useful x 1
  3. Hmm... thanks for the suggestion. I will try it. We're running McMMO 1.5.00-b3547, but I see there is a 1.5.03-SNAPSHOT-b46.
     
  4. Make sure you tell us the result ;)
     
    • Agree Agree x 1
  5. Okay, the update was successful, and I saw these lines during the restart:

    Code (Text):
    [00:00:16] [Craft Scheduler Thread - 12/INFO]: [mcMMO] Starting to check and update UUIDs, total amount of users: 170
    ...
    [00:00:29] [Craft Scheduler Thread - 12/INFO]: [mcMMO] UUID upgrade completed!
    Now, I'm hoping that will make the intermittent crash on restart go away. I'll only post if I see the crash again!

    Thanks so much for your help!
     
  6. No problem. Good luck!
     
  7. Actually, now that I upgraded, I'm getting these McMMO exceptions:
    http://pastebin.com/k32uYeXD
    :( So, I'm gonna revert the mcMMO plugin back to what it was for now. :(
     
  8. Reverting back wasn't a good idea. The server was completely frozen.

    So, I put mcMMO back to 1.5.03-SNAPSHOT-b46, and I suppose I'm gonna have to live with these exceptions http://pastebin.com/k32uYeXD every 10 minutes(?).
     
  9. u should inform the dev of mcmmo about
     
  10. Hmm, ye, but I haven't been seeing them since the second restart after updating mcMMO. :)
     
  11. Sorry, I didn't see you post this!

    It's good to know that it isn't coming back up again. I think it may have been something to do with the initial UUID conversion.

    EDIT: Just found this: https://github.com/mcMMO-Dev/mcMMO/issues/2225

    which confirms it was to do with the conversion, and it is fixed (apparently :p)
     
  12. I think you're right, Jamy! :) Have a good day.