Server stopped responding, please help!

Discussion in 'Spigot Help' started by Juan_010, Jul 20, 2018.

  1. I've recently moved my whole network from an 8GB VPS, to 2 VPSs, a 16GB VPS and a 4GB VPS. Both connected through BungeeCord. I have assigned my lobby 4 GB out of the 16GB VPS. When I log in, it takes a few seconds to kick me and then it logs this to the console.
    https://pastebin.com/1iWmtySa
    I'm aware there are some plugins here, such as CompassManager, TitleManager and Noteblock API. However, I don't think thats the problem here. Previously, it ran flawlessly with only 2GB RAM, but now this is happening. I don't know what to do, please help!
    UPDATE: It seems to kinda solve itself when I lower the Ram that it is assigned. My VPS is a 16GB, and only 15GB are allocated. I lowered it to 3.5 GB RAM and now it works kinda fine? this is weird
     
    #1 Juan_010, Jul 20, 2018
    Last edited: Jul 23, 2018
  2. Have you made sure that all servers on the bungee are on the same version, along with all plugins?

    Also, what Java version are you using?

    Do the server startup and stay online for a little, or immediately crash?
     
  3. I literally copy-pasted what was working in another VPS. It stays online until someone logs in and tries to use something. I initially thought that it only happened with the Compass that CompassManager set up, but if I use anything, say a fishing rod, it just stops responding. Then, if I try to restart it, I see there is a frozen instance of the same server running, so I can’t restart it.
     
  4. Try removing plugins 1 by 1 to see if the issue persists.
     
  5. I have around 80 plugins, that would be far too difficult.
    UPDATE: Another one of my servers suffers from this exact thing. The only thing that changes is that this happens when I do /reload, but that only happens when someone is connected. I will link a pastebin URL later, but this is driving me nuts.
     
  6. NEVER use /reload. If you need to make changes to plugins or files, stop your server, make the changes and then start it back up. This might be contributing to your issue.

    EDIT: If it's a plugin causing the issue, you are going to have to remove some at a time to see if the issue is still present. 80 plugins is way too many also. You could probably cull them down.
     
  7. Yeah, I'm aware of that. In the server that freezes on stop, I have tracked the plugin down but... I can't remove that one. The plugin is Skript, Mirreski's fork to be exact. This one is literally the center of this server and it was working just fine in the other host. I tried erasing the folder, so it generates a new one. No luck. I feel like I could Conde the same script on Java, but I still have to learn a lot and the Skript is around 700 lines, I think it would be even longer in Java.
     
  8. Skript is not the same a Java as it's a lot more intensive if it was to be coded in Java. I would suggest trying to get a developer to develop the plugin for you.

    If you can't get it developed, try updating it as much as you can. It might even be a plugin hooking into Skript that is causing the issue. Try everything. Remove any other plugins that would hook into Skript, to see if that fixes the issue.