Spigot Server Tutorial Plus 1.24.1

Introduce players to your server with unlimited tutorials! Many customisations! Free!

  1. i found another problem , i tried to start the tutorial and he give me an internal error, after the tutorial i can't move anymore, i tried to remove the plugin but nothing. Another thing, when i tried to move the mouse with lockplayer my visual start to go crazy.
     
    • Agree Agree x 1
  2. Not work
     
  3. Please help.

    After playing around with tutorials and the lockplayer flag, I have somehow managed to get myself unable to move around after the tutorial has completed, although I can still look around.

    It may have been because I did `/st playpoint' twice immediately after each other, but now my console is constantly spamming "WARN (player) moved too quickly!" whenever I try to move.

    Other accounts are still able to move freely, except for mine. I have tried restarting the server and uninstalling the plugin, but there is no affect.

    I believe _zMattyPower_ also has a similar problem, according to his post in the discussion and review. His wording in the review was not very clear, and he was talking about after the tutorial, and not during.
     
    #223 PaisWillie, Aug 9, 2017
    Last edited: Aug 10, 2017
  4. Okay, it seems like you found a bug with /playpoint. I think that I know what is causing this. Your momementspeed is set to 0.
    The only way to fix this is to use the essentials command to set walk speed. (Don't know it from my head but could be /walkspeed)

    I am currently on vacation but I will try to fix this once I am back.

    Sorry for the inconvenience :(
    (Wifi is not that good here)
     
  5. Now I understand why it took you a bit of a while to reply, but that's okay, cause I'm also at a family cottage sharing wifi between ten people :p

    Don't know about /walkspeed but I do know that if you are not flying and you do /speed it will only affect your walk speed. I will try that when I get back from my trip.

    EDIT: Both /walkspeed and /speed worked and has fixed my problem. Also note that /flyspeed was forcefully set to 0, and you have to do /flyspeed 1 to fix it.
     
    #225 PaisWillie, Aug 11, 2017
    Last edited: Aug 13, 2017
    • Like Like x 1
  6. Kinda, I just prevent it from happening ;)
     
  7. Hello ! I have a little question, I put this command "/st edit tutorial 1 add potioneffect INVISIBILITY 40 1" BUT, the potion of invisibility have the time of "1.20 min" not 4 sec. Its a wrong by me or.. ?
    Thank you!
     
  8. I just added the command "effect %player_name% minecraft:invisibility 4 0 true". At first it spammed the chat with console commands, but I just disabled it in the essentials configuration, ConsoleToOPS or something.
     
  9. Will look into it when I am back home again.
     
  10. Great plugin!
    It would be very useful if you could add the option to replace the teleport by a "You must follow this Particel trace" feature. :)

    When new players are teleported, they quickly lose their orientation.
    So they know what features there are, but in the end they don't find it.
     
  11. Hey there guys!
    I am a bit late with it but thank you all for 800 downloads <3
    The plugin got handles more players then I could ever think it would :D
    BStats

    Some people told me that I should make this plugin premium, and although, the money would be nice, I just cannot do it since this plugin has always been free, and so it will be.

    Currently working on a update that separates the movement lock and view lock + fixing some bugs ;)
     
    #233 MartenM, Aug 27, 2017
    Last edited: Aug 27, 2017
  12. The time is in seconds. So it would be:
    Code (Text):
    /st edit tutorial 1 add potioneffect INVISIBILITY 4 1
     
  13. Does it also work on a 1.8?
     
  14. Some functions do, some don't. I do not support 1.8 but you can always try :^/
     
  15. Error console:
    [20:20:26] [Craft Scheduler Thread - 2088/WARN]: [Server Tutorial Plus] Plugin ServerTutorialPlus v1.6.4 generated an exception while executing task 1814381
    java.util.ConcurrentModificationException
    at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901) ~[?:1.8.0_72]
    at java.util.ArrayList$Itr.next(ArrayList.java:851) ~[?:1.8.0_72]
    at com.martenm.servertutorialplus.objects.TutorialController$2.run(TutorialController.java:60) ~[?:?]
    at org.bukkit.craftbukkit.v1_11_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.11.2.jar:git-Spigot-d4f98a3-cb61ac0]
    at org.bukkit.craftbukkit.v1_11_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52) [spigot-1.11.2.jar:git-Spigot-d4f98a3-cb61ac0]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_72]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_72]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72]
     
  16. Where you editing the tutorial while people were playing it (or you)?
     
  17. i don't think so. I was alone.