Solved Server Type Conversion?

Discussion in 'Spigot Help' started by Keris, Jun 16, 2016.

  1. Hey guys,

    I've been playing on a spigot server for about a month now, and we recently noticed some strange behavior on our server.

    With the 1.10 update, we noticed that:
    1. Xp orbs no longer group together
    2. The server login page no longer said spigot 1.x.x
    3. The F3 screen says vanilla
    4. Mob AI changed drastically
    5. Chunk loading changed, and elytra became unfeasible as a means of travel due to void chunk boundaries
    6. The nether and end completely regenerated
    7. The server admin hadn't touched the server settings

    It is apparent to me that the server was converted to a vanilla server. How is this possible? Our admin hasn't been on for a while, and says he did not touch anything on the server. I'm inclined to believe him. How is this possible? I can't seem to make sense of it. The server admin says it looks as though spigot is still configured on his end. Is anyone else experiencing issues like this? Is there a test that I can do to verify whether the server is vanilla/spigot?

    We are using an external host if that is needed by anyone.
     
  2. MiniDigger

    Supporter

    enter /version. This will show something if you are running spigot/bukkit.
    Seems like your admin doesn't know what he does.
     
  3. The problem is that the admin isn't really active. He hasn't been around to make changes to the server for a while now, and we have had trouble getting a hold of him to make the needed changes to the server. That being said, I find it unlikely that he altered the server, seeing as he doesn't ever touch it. Of course it could be that he changed something, but I feel as though that is a significant change to the server that he would have been aware of. Is it possible that something subtle or even passive converted the server to vanilla or causes bukkit/spigot servers to act as a vanilla server?
     
  4. MiniDigger

    Supporter

    no. it looks like your admin tried to update the server using a control panel and pressed some wrong buttons
     
  5. Okay. I figured as much, but I'm no expert on spigot by any means. We verified that the server is now in fact a vanilla server. I'll talk with our admin and see if we can figure out the root of the issue based on what happened.