Server wont launch and throws up multiple errors

Discussion in 'Spigot Plugin Help' started by Topsie_Cow, Jan 21, 2020.

  1. And the error says it all:
    Code (Text):
    [WARNING] Plugin SimpleHolograms v1.0.0 does not specify an api-version.
    [ERROR] Could not load 'plugins/SH.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: net.minecraft.server.v1_7_R1.Packet
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139) ~[spigot-1.15.1.jar:git-Spigot-037559e-661bebc]
     
    The error is saying you are trying to load a plugin written for 1.7.x on your 1.15.1 server.
    A simple search of SimpleHolograms shows that said plugin has not been updated since 2014...
    Screen Shot 2020-01-20 at 9.28.25 PM.png


    That about sums that up for ya.



    ALSO:
    Code (Text):
    **********************************************
    ** This WorldEdit version does not fully support your version of Bukkit.
    **
    ** When working with blocks or undoing, chests will be empty, signs
    ** will be blank, and so on. There will be no support for entity
    ** and block property-related functions.
    **
    ** Please see https://worldedit.enginehub.org/en/latest/faq/#bukkit-adapters
    **********************************************
     
    • Informative Informative x 1
  2. Hello update SimpleHologram plugin, ProtocolLib plugin,
     
    • Optimistic Optimistic x 1
  3. Bruh can u atleast look at ShaneBee's reply? Bukkit.org clearly shows that Simple Holograms literally only has one version. 1.7.2. And you want him to update, code it for him, he'll be happy.
     
    #4 Wilsoon, Jan 25, 2020
    Last edited: Jan 25, 2020
    • Funny Funny x 1
    • Winner Winner x 1