ServerConnector issue

Discussion in 'BungeeCord Help' started by darthdoesmc, May 10, 2016.

  1. Hey!
    Wherever I want to join my 1.9 server on the network I can't seem to join, this just gets printed in console of the proxy.

    My BungeeCord version is 1.9 and the server version for Spigot is 1.9.2. The server on Spigot is in offline mode with BungeeCord setting enabled in Spigot.yml

    I can connect to other 1.8 servers on the network but not to the 1.9 server using a forcedhost/command.
    Code (Text):
    23:23:24 [INFO] [darthdoesmc] <-> ServerConnector [S2] has connected
    23:23:24 [INFO] [darthdoesmc] <-> ServerConnector [S2] has disconnected
    Any ideas?

    Thanks!
     
  2. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    For connecting to a 1.9.2 server, you will need a 1.9.2 client.
     
  3. Yeah, I'm using a 1.9 Client. It still doesn't work.
     
  4. When pinging the server directly on my server list (without a forced host) it says...
    [​IMG]
    When I attempt to connect I get this.
    [​IMG]
     
  5. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    you will need a 1.9.2 client. If you are using a 1.9.2 client, please give us your spigot server logs and your bungee config.
     
  6. Using 1.9.2 Optifine.

    Connecting to the server DIRECTLY (not through a forced host or command within Bungee doesn't do anything AT ALL in console and just gives that disconnected message.)
    Connecting to the server USING THE FORCED HOST I set up just stays on the "Logging in..." screen. This is posted in Bungee console.
    Code (Text):
    16:59:10 [INFO] [darthdoesmc] <-> ServerConnector [S2] has connected
    16:59:10 [INFO] [darthdoesmc] <-> ServerConnector [S2] has disconnected
    16:59:15 [INFO] [/92.222.71.15:48838] <-> InitialHandler has connected

    16:59:25 [INFO] [/92.222.71.15:48881] <-> InitialHandler has connected
    Eventually it says "Disconnected". (See image above).
    NOTHING is posted in the server console.

    This is my BungeeCord configuration.
    Code (Text):
    ip_forward: true
    network_compression_threshold: 256
    stats: 66cba5f0-5102-4c7b-934b-xxxxxxxxxxxxx
    groups:
      darthdoesmc:
      - proxyadmin
    servers:
      Lobby:
        motd: |-
          A MOTD
          PLACEHOLDER
        address: X:25566
        restricted: false
      S1:
        motd: '&c&lDDMC - S1'
        address: X:X
        restricted: false
      S2:
        motd: '&c&lDDMC - S2'
        address: X:X
        restricted: false
      D1:
        motd: '&c&lDDMC - D1'
        address: X:X
        restricted: false
    timeout: 30000
    player_limit: 30
    listeners:
    - query_port: 25565
      motd: X
      tab_list: SERVER
      query_enabled: true
      forced_hosts:
        MC.X.X: Lobby
        S2.X.X: S2
        S1.X.X: S1
        DEV.X.X: D1
      ping_passthrough: false
      bind_local_address: true
      host: X.X.X.X:25565
      max_players: 30
      tab_size: 60
      force_default_server: true
      priorities:
      - Lobby
      - S2
    permissions:
      default:
      - X
      proxyadmin:
      - X
    online_mode: true
    log_commands: true
    disabled_commands:
    - end
    connection_throttle: 4000
    I removed some things and replaced them with X. I hope this is not too much of a inconvenience.
     
  7. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Can you directly connect to the spigot server? without using bungee?
     
  8.  
  9. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Than is something wrong with your network setup. If you can't even join directly to your spigot server and the spigot console shows nothing. Server listening on the wrong ip/port?
     
  10. That's in my latest.log
    [​IMG]
    The exact same port and IP is in my Bungee config.

    I'll see if it's an error when with my VPS.
     
  11. Nope, I just have no idea. Got a feeling it's an issue with some of my plugins so looking into that.
     
  12. The problem is not with your bungeecord but with your spigot or VPS / VDS.
     
  13. Ahhh, do I need to change anything? Any ideas on how to fix?
     
  14. FHR

    FHR

    Firewall? If it's a dedicated server/VPS, post output of "iptables -L"
     
  15. [​IMG]
    [​IMG]
     
  16. FHR

    FHR

    Hmm, that looks all right. What is the listening IP? In server.properties try removing listening IP setting.
    The line in server.properties will then look like this:
    Code (Text):
    server-ip=
     
  17. The software I use to manage the server automatically adds the correct address and port.
     
  18. No idea what was happening but it was something to do with my network plugin updater. It automatically updates the plugins and files across the network and it just looks like this was not liked on 1.9. Causing issues with permissions and jars that the updater created.
    It's only a temporary fix but good enough for me.

    Thank you everyone who tried to help.