Spigot ServerLogin with GUI - Create a password for your server 2.1

Make your server secure & private | NOW WITH SHA256

  1. MaveCrit submitted a new resource:

    ServerLogin with GUI - Creating a password for your server - You want to make your server a little bit more private? Use ServerLogin!

    Read more about this resource...
     
  2. /serverlogin only works only for players not for the console.
    To join the server please change the password manually in the config.yml or use the default password "0000" to join. :)
     
  3. Which password :D?
     
  4. i like the idea but need more stuffs! :D Thanks for sharing man
     
  5. Just say me what is should add :D
     
  6. you can add custom description to nbt tag in the head?
    [​IMG]
     
  7. Fits be replaced by the plugin Authme reload?
     
  8. Ive didnt tested it with other plugins is there a problem when running it together with Authme?
     
    • Like Like x 1
  9. Good morning, no, on the contrary, I do not wanna use the authme reload because this buggy on my server and I am trying to replace it with another plugin, and I could see her released here, so I asked the question, wondering if with your plugin, it has the same registration function for login? thank you.
     
  10. No, AuthMe is really really different.
    With this plugin you can create a password for the full server.
    So if you set the password to "mave", EVERY player has to enter the password "mave"
    its not user specific, its just like a "whitelist" but cooler :D
     
    • Agree Agree x 1
  11. Some error ???. I use spigot 1.8.8 . and I install this plugin . but , in game , this plugin not show GUI to login.
     
  12. The current version is for 1.9

    Search in the version history for 1.8
     
    • Like Like x 1
  13. So 1.8 will not support anymore ?
     
  14. There will be no updates anymore but the Version still works
     
    • Like Like x 1
  15. hub

    hub

    Hello.
    Sadly its not working in 1.9.4, i tried 1.9 and 1.9.2 and got the login screen.
    Do you have any plans to fix it?
     
    #18 hub, May 24, 2016
    Last edited: May 25, 2016
  16. I just set up a 1.9.4 server and was looking for a global password plugin. but the login gui doesn't show up.

    This is what shows on console when someone enter:

    P.S.: I renamed my 1.9.4 spigot.jar to "spigot-1.8.8-R0.1-SNAPSHOT-latest.jar" because my panel would switch to bukkit 1.5.2 when custom jar is selected =_='''

    [03:33:36] [Server thread/WARN]: [ServerLogin] Task #12 for ServerLogin v1.0 generated an exception
    java.lang.NoClassDefFoundError: net/minecraft/server/v1_9_R1/EntityHuman
    at de.mavecrit.serverlogin.Main$2.run(Main.java:111) ~[?:?]
    at org.bukkit.craftbukkit.v1_9_R2.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at org.bukkit.craftbukkit.v1_9_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at net.minecraft.server.v1_9_R2.MinecraftServer.D(MinecraftServer.java:734) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at net.minecraft.server.v1_9_R2.DedicatedServer.D(DedicatedServer.java:399) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at net.minecraft.server.v1_9_R2.MinecraftServer.C(MinecraftServer.java:665) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at net.minecraft.server.v1_9_R2.MinecraftServer.run(MinecraftServer.java:564) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at java.lang.Thread.run(Thread.java:745) [?:1.7.0_85]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_9_R1.EntityHuman
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:91) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-4af49dc-c5e9a16]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_85]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_85]
    ... 8 more

    Looking for "git-Spigot-4af49dc-c5e9a16" on google took me to github where it said :

    spigot 1.9.4 causing issues with version 1.9

    Also there is this "CritBlood enabled".... dafuq is that?
     
  17. The current Version is made for 1.9.2 i will Upload a 1.9.4 one this evening.
    Thanks for reporting