Session.lock??

Discussion in 'Spigot Help' started by korbynullvig, Jun 4, 2017.

  1. So I run multicraft and when i download a world or take a world from one of my servers, Multicraft doesent start a server becuase of an error

    Code (Text):
    04.06 18:12:51 [Server] WARN java.io.FileNotFoundException: ./world/session.lock (Permission denied)
     
  2. Its an permission error on your server try contacting your host about it
     
  3. My host?
    I own my host
     
  4. Its an permission error in Linux where your Multicraft user doesn't have access to read/write the file
     
  5. How do i give it permission?
     
  6. electronicboy

    IRC Staff

    This is generally why basic linux skills are essential when running your own server on a linux box.

    cd to the /home folder, and basically, work out which folder is for the server you're having issues with and chown the folder, last I recall, multicraft was at least sane enough to create username and user folder mappings, so chown -R <serverdir> <serverdir>

    that shouldn't break anything with how their system worked last I recall, however: I offer no guarantee that that may or may not break the server, especially in the event of running the command improperly.
     
  7. Huh. Well ill have my guy do it SO i dont break anything :D

    But Is there a way to bypass it right now without giving permission to anything?
     
  8. Ive tried importing it with multicraft but Multicraft doesent find it
     
  9. Just to be sure is this correct?
    @electronicboy

    chown -R minecraft:minecraft /home/minecraft/multicraft/servers/server11/Gf1
     
  10. electronicboy

    IRC Staff

    no, there is no way to bypass it without screwing up security or creating bigger issues in the long run, and if that's the correct user then that would work, however that doesn't look like a normal folder structure, server11 would look like the correct user, for the group, I would probably just run ls -l in the servers folder and double check what the user/group is on that, or in the folder.
     
  11. Code (Text):
    total 81408
    -rw-------.  1 root root     2590 Apr 13 09:08 anaconda-ks.cfg
    -rw-r--r--.  1 root root    16931 Apr 13 09:08 install.log
    -rw-r--r--.  1 root root     6154 Apr 13 09:07 install.log.syslog
    -rw-r--r--   1 root root 49140561 Oct  2  2015 jre-8u60-linux-x64.rpm
    drwxr-xr-x  10 1000 1000     4096 Apr 13 09:32 multicraft
    -rw-r--r--   1 root root 34177934 Dec  8 03:12 multicraft.tar.gz
     
     
  12. Ive tried the things you said to do But notthing works.
     
  13. electronicboy

    IRC Staff

    then you've done it wrong. you're better off waiting until your friend or whomever is back, as I've said, commands like chmod and chown can cause issues if improperly used.