Setting up FAWE and FAVS (or normal Voxelsniper) on a localhosted spigot server

Discussion in 'Spigot Plugin Help' started by Ivain, Sep 30, 2018.

  1. So I've been struggling with this for a while. I'm using a localhosted server because right now I do not have an internet connection stable enough to connect to something like Builder's Refuge in many cases.
    Yet for some reason, Voxelsniper just never turns up. I've followed all suggested instructions, not installed normal worldedit, and tried both FAVS and normal VS.
    The plugin just never registers. FAWE does, and a combination of normal WE and VS does work, but I don't want to do without the improved options of FAWE.
    I'd like to see if I can get Builder's Utilities and stuff set up as well but thats for once I realize what the problem is here.

    Edit: Currently looking to stay in 1.12, until I'm 100% sure all plugins I might want to use fully support 1.3
     
    #1 Ivain, Sep 30, 2018
    Last edited: Sep 30, 2018
  2. I made my own Spigot 1.13.1 with buildtools yesterday, i got fawe from their page and it said to not use worldedit and use their build of worldguard, i got that, run the server: works fine. https://empcraft.com/fawe/download/
     
  3. Even after I removed Worldedit, it still didn't work. Do I NEED worldguard?
     
  4. Looks like I need to bump
     
  5. Can't reproduce the issue.

    I get a new buildtools, I use it to get a new 1.13.1 spigot, i run that, put the fawe and worldguard builds they tell you to use in the plugins dir, and load it: things work.
     
  6. Ok, so buildtools, FAWE, VS and Multiverse are all up to date with 1.13, then? That's great, I'll have to create a new server for that, once my internet recovers from its pit of 800kb/s
    I still have the problem that my 1.12.2 server won't work. This is relevant because I absolutely do not want to risk corrupting my 1.12 worlds, and afaik there's still no 100% stable 1.13 build for spigot.
    I'll doublecheck it and upload a zipfile of the plugins folder if I can't get it to work.
     
  7. Not sure what you mean with this.
     
  8. Well, if I'm unable to make it work in 1.12 what you can apparently create flawlessly in 1.13, I'll have to ask someone to check the plugins I have and see if there's anything wrong with it or if I have made any stupid mistakes. Ofc, now that Ive thought about it a screenshot of my plugins folder should do.
     
  9. Use the stable builds of we/wg/fawe for 1.12.2. This is what I did: First I installed Vault and Worldedit, and then worldguard for 1.12.2, and then fawe on top.

    https://dev.bukkit.org/projects/vault/files Vault 1.5.6
    https://dev.bukkit.org/projects/worldedit/files WorldEdit 6.1.9 (up to MC 1.12.2)
    https://dev.bukkit.org/projects/worldguard/files WorldGuard 6.2.2 (for MC 1.12.2)
    https://empcraft.com/fawe/download/?bukkit FAWE for Bukkit 1.12.2
     
  10. alright I'l follow that exactly.