1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Severe lag when hosting Survival Games for about 30 minutes

Discussion in 'Bugs & Feature Requests' started by Tom Wells, Apr 4, 2013.

  1. Hey,

    To cut a long story short, after a short while of hosting a Survival Games I get severe lag whilst hosting a Survival Games server using Spigot. I use the Survival Games plugin along with PermissionsEx, Essentials and WorldEdit and it all seems to run fine. Then, as I mentioned, about 30 minutes into the game I get severe lag on my whole dedicated server.

    At first I thought we could have been being attacked with a DDoS, but other things on the server (websites and the such) load perfectly fast and fine. If it was a port, would the whole dedicated server not allow logins because it's going so slow? On any account?

    I should note at this point that I run another Minecraft server fine with usual plugins and about 20 people coming on per day and I have no lag whatsoever so I feel like it's a problem with the Survival Games plugin, but cannot find anyone with the issue elsewhere.

    The server specs are the following:
    Intel i5 2400 (Quad Core) @ 3.1GHz / 3.4GHz Turbo Boost
    16GB DDR3
    A ton of hard drive space

    so I don't think that should be the problem really? I could be wrong...

    Does anyone have any ideas? I get no errors on the server whilst running and the lag lasts for about 5 minutes and is just at a random time.

    Thanks!