[SEVERE] [Metrics] Server returned HTTP response code: 504 for URL:

Discussion in 'Server & Community Management' started by EatingEmoKids, Mar 1, 2013.

  1. EatingEmoKids

    Supporter

    Hi Guys, not sure if this is a spigot bug and belongs in that forum or is just something wrong with my server.

    I get this error poping up in console and at the same time the server lags out pretty hard for what seems to be about 30 seconds and then everything goes back to normal.

    Code (Text):
    [SEVERE] [Metrics] Server returned HTTP response code: 504 for URL: http://mcstats.org/report/Spigot
    Any ideas on what might be causing this and how to prevent it?

    Thanks!
     
  2. md_5

    Administrator Developer

    Happens every time Metrics goes down. Its absolutely nothing to do with your lag since this code is in a different thread.
     
  3. I just disable the metrics while it does that. It does spam the log.
     
  4. Puremin0rez

    Moderator

    It's a perfectly normal error. Not sure why it says severe, but it's perfectly normal to see that.

    Metrics goes down quite often, so get used too it or disable metrics :p
     
    • Agree Agree x 1
  5. EatingEmoKids

    Supporter

    can someone tell me how to disable the metrics? It seems very consistent with the metric error and the server lag issue, always happening together.
     
  6. md_5

    Administrator Developer

    /me head desks. They are so completely unrelated it isn't even funny. Its all in your head. If you are really desperate and misinformed you can edit the PluginMetrics folder. In fact I'm going to hide that message just so people like you don't go chasing after wild geese.

    EDIT: What version are you on, this hasn't even existed since the metrics rewrite.
     
    #6 md_5, Mar 7, 2013
    Last edited: Mar 7, 2013
  7. EatingEmoKids

    Supporter

    I'm simply just trying to figure out whats causing the problem, and I've tried removing plugins that are performing task around these lag spikes and it's still happening, so I'm just trying to rule this out.

    Currently using the latest promoted build: 485
     
  8. I wonder why metrics spits out a servere error. Bad for simple crash detection & restart...