Spigot Shop 2.1.0

Shop is a plugin that allows you to setup a large shop that works with commands, NPCs, and signs.

  1. Was using this mod and I can't seem to figure out how to use it properly. Whenever i use any of the /shop commands a pop up appears that has a bunch of pregenerated shop tabs, that when clicked, have preset prices, and items listed, so i am unable to use the plugin. Lemme know if anyone has a fix! or knows what I'm doing wrong
     
  2. Hiya'll,

    I must first say a happy 2018 to ya all, but I started to work with shop and it did not give me satisfaction at all, sorry dev, so i went over to a paid version that does all so much better. Now I am not telling ya'all to go buy this because there are also people who still can't afford it, so I only wanted to message that despite the fact they both share the same name and foldername, which is confusing and not be able to use on one server.
    If this only would change on one of them all, I can still make use of this plugin...
    Thanks
     
  3. Thanks for the response. Here is a picture of my .jar plugin files below.
     

    Attached Files:

  4. I also figure this is useful too - this is the output at server start so you have versions. Everything should be at its most updated.

    Code (Text):
    XXXXXXXX>java -jar craftbukkit.jar
    Loading libraries, please wait...
    [08:12:08 INFO]: Starting minecraft server version 1.12.1
    [08:12:08 INFO]: Loading properties
    [08:12:08 INFO]: Default game type: SURVIVAL
    [08:12:08 INFO]: Generating keypair
    [08:12:08 INFO]: Starting Minecraft server on XXXXXXXX
    [08:12:08 INFO]: Using default channel type
    [08:12:09 INFO]: This server is running CraftBukkit version git-Bukkit-8f47214 (MC: 1.12.1) (Implementing API version 1.12.1-R0.1-SNAPSHOT)
    [08:12:10 INFO]: [AdvancedPortals] Loading AdvancedPortals v0.0.36
    [08:12:10 INFO]: [WorldEdit] Loading WorldEdit v6.1.8-SNAPSHOT;cd4729f
    [08:12:10 INFO]: [GroupManager] Loading GroupManager v2.0.1-b332
    [08:12:10 INFO]: [DropHeads] Loading DropHeads v3.1.3
    [08:12:10 INFO]: [NewPlayerWelcome] Loading NewPlayerWelcome v1.0
    [08:12:10 INFO]: [Vault] Loading Vault v1.6.1
    [08:12:10 INFO]: [LaggRemover] Loading LaggRemover v2.0.2
    [08:12:10 INFO]: [SimpleTicketManager] Loading SimpleTicketManager v2.1.0
    [08:12:10 INFO]: [ProtocolLib] Loading ProtocolLib v4.3.0
    [08:12:10 WARN]: [ProtocolLib] Version (MC: 1.12.1) has not yet been tested! Proceed with caution.
    [08:12:10 INFO]: [WorldGuard] Loading WorldGuard v6.2.1;84bc322
    [08:12:10 INFO]: [Orebfuscator4] Loading Orebfuscator4 v4.3.3
    [08:12:10 INFO]: [Essentials] Loading Essentials v2.0.1-bSNAPSHOT
    [08:12:10 INFO]: [EssentialsProtect] Loading EssentialsProtect v2.0.1-bSNAPSHOT
    [08:12:10 INFO]: [BKCommonLib] Loading BKCommonLib v1.12.2-v3
    [08:12:13 INFO]: [EssentialsChat] Loading EssentialsChat v2.0.1-bSNAPSHOT
    [08:12:13 INFO]: [EssentialsGeoIP] Loading EssentialsGeoIP v2.0.1-bSNAPSHOT
    [08:12:13 INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.0.1-bSNAPSHOT
    [08:12:13 INFO]: [Shop] Loading Shop v2.1.0
    [08:12:13 INFO]: [SignLink] Loading SignLink v1.12.2-v3
    [08:12:13 INFO]: [EssentialsSpawn] Loading EssentialsSpawn v2.0.1-bSNAPSHOT
    [08:12:13 INFO]: [EnjinMinecraftPlugin] Loading EnjinMinecraftPlugin v3.4.3
    [08:12:13 INFO]: [Train_Carts] Loading Train_Carts v1.12.2-v1
    [08:12:13 INFO]: [Vault] Enabling Vault v1.6.1
    [08:12:13 INFO]: [Vault] [Economy] Essentials Economy found: Waiting
    [08:12:13 INFO]: [Vault] [Permission] GroupManager found: Waiting
    [08:12:13 INFO]: [Vault] [Permission] SuperPermissions loaded as backup permission system.
    [08:12:13 INFO]: [Vault] [Chat] GroupManager found: Waiting
    [08:12:13 INFO]: [Vault] Plugin enabled (109ms)
    [08:12:13 INFO]: [ProtocolLib] Enabling ProtocolLib v4.3.0
    [08:12:13 INFO]: [ProtocolLib] Started structure compiler thread.
    [08:12:13 INFO]: [Orebfuscator4] Enabling Orebfuscator4 v4.3.3
    [08:12:13 INFO]: [OFC] World type 'Default' has been read.
    [08:12:13 INFO]: [OFC] World type 'Normal' has been read.
    [08:12:13 INFO]: [OFC] World type 'TheEnd' has been read.
    [08:12:13 INFO]: [OFC] World type 'Nether' has been read.
    [08:12:13 INFO]: [OFC] Proximity Hider is Enabled
    [08:12:14 INFO]: [BKCommonLib] Enabling BKCommonLib v1.12.2-v3
    [08:12:14 INFO]: [BKCommonLib] BKCommonLib is running on CraftBukkit (git-Bukkit-8f47214) : v1_12_R1 (Minecraft 1.12.1)
    [08:12:14 INFO]: [BKCommonLib] [Network] Now using the ProtocolLib library to provide Packet Listener and Monitor support
    [08:12:14 INFO]: [BKCommonLib] Providing support for supporting the unsupportable.
    [08:12:15 INFO]: [BKCommonLib] BKCommonLib version 1.12.2-v3 (build: 251) enabled! (0.963s)
    [08:12:15 INFO]: Preparing level "world"
    [08:12:15 INFO]: Preparing start region for level 0 (Seed: XXXXXXXXXXX)
    [08:12:16 INFO]: Preparing spawn area: 23%
    [08:12:17 INFO]: Preparing spawn area: 75%
    [08:12:18 INFO]: Preparing start region for level 1 (Seed: XXXXXXXXXXX)
    [08:12:18 INFO]: Preparing start region for level 2 (Seed: XXXXXXXXXXX)
    [08:12:18 INFO]: [AdvancedPortals] Enabling AdvancedPortals v0.0.36
    [08:12:18 INFO]: [AdvancedPortals] BLOCK_PORTAL_TRAVEL found
    [08:12:18 INFO]: [AdvancedPortals] ENTITY_ENDERMEN_TELEPORT found
    [08:12:18 INFO]: [AdvancedPortals] ENTITY_GENERIC_EXPLODE found
    [08:12:19 INFO]: Advanced portals have been successfully enabled!
    [08:12:19 INFO]: [WorldEdit] Enabling WorldEdit v6.1.8-SNAPSHOT;cd4729f
    [08:12:19 INFO]: WEPIF: Using the Bukkit Permissions API.
    [08:12:19 INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_12_R2 as the Bukkit adapter
    [08:12:19 INFO]: [GroupManager] Enabling GroupManager v2.0.1-b332
    [08:12:19 INFO]: GroupManager - INFO - World Found: world
    [08:12:19 INFO]: GroupManager - INFO - Superperms support enabled.
    [08:12:19 INFO]: GroupManager - INFO - Scheduled Data Saving is set for every 10 minutes!
    [08:12:19 INFO]: GroupManager - INFO - Backups will be retained for 24 hours!
    [08:12:19 INFO]: GroupManager version 2.0.1-b332 is enabled!
    [08:12:19 INFO]: WEPIF: GroupManager detected! Using GroupManager for permissions.
    [08:12:19 INFO]: [Vault][Permission] GroupManager hooked.
    [08:12:19 INFO]: [Vault][Chat] GroupManager - Chat hooked.
    [08:12:19 INFO]: [DropHeads] Enabling DropHeads v3.1.3
    [08:12:19 INFO]: [NewPlayerWelcome] Enabling NewPlayerWelcome v1.0
    [08:12:19 INFO]: [LaggRemover] Enabling LaggRemover v2.0.2
    [08:12:19 ERROR]: [LaggRemover] Plugin LaggRemover v2.0.2 has failed to register events for class drew6017.lr.main.Events because org/bukkit/event/entity/EntitySpawnEvent does not exist.
    [08:12:19 INFO]: [LaggRemover] Loaded 0 module(s)
    [08:12:19 INFO]: [LaggRemover] The LaggRemover AI is now active!
    [08:12:19 INFO]: [LaggRemover] LaggRemover has been enabled!
    [08:12:19 INFO]: [SimpleTicketManager] Enabling SimpleTicketManager v2.1.0
    [08:12:19 INFO]: [SimpleTicketManager] Simple Ticket Manager is starting up. This may take a while!
    [08:12:19 INFO]: [SimpleTicketManager] Simple Ticket Managers has been successfully enabled!
    [08:12:19 INFO]: [WorldGuard] Enabling WorldGuard v6.2.1;84bc322
    [08:12:20 INFO]: [WorldGuard] (world) TNT ignition is PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world) Lighters are PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world) Lava fire is blocked.
    [08:12:20 INFO]: [WorldGuard] (world) Fire spread is UNRESTRICTED.
    [08:12:20 INFO]: [WorldGuard] Loaded configuration for world 'world'
    [08:12:20 INFO]: [WorldGuard] (world_nether) TNT ignition is PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world_nether) Lighters are PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world_nether) Lava fire is blocked.
    [08:12:20 INFO]: [WorldGuard] (world_nether) Fire spread is UNRESTRICTED.
    [08:12:20 INFO]: [WorldGuard] Loaded configuration for world 'world_nether'
    [08:12:20 INFO]: [WorldGuard] (world_the_end) TNT ignition is PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world_the_end) Lighters are PERMITTED.
    [08:12:20 INFO]: [WorldGuard] (world_the_end) Lava fire is blocked.
    [08:12:20 INFO]: [WorldGuard] (world_the_end) Fire spread is UNRESTRICTED.
    [08:12:20 INFO]: [WorldGuard] Loaded configuration for world 'world_the_end'
    [08:12:20 INFO]: [WorldGuard] Loading region data...
    [08:12:20 INFO]: [Essentials] Enabling Essentials v2.0.1-bSNAPSHOT
    [08:12:20 INFO]: [Essentials] Using 1.8.3+ BlockStateMeta provider as mob spawner provider.
    [08:12:20 INFO]: [Essentials] Using Reflection based provider as spawn egg provider.
    [08:12:20 INFO]: [Essentials] Using 1.9+ BasePotionData provider as potion meta provider.
    [08:12:20 INFO]: Using locale en_US
    [08:12:21 INFO]: [Essentials] Using Spigot 1.7.10+ ServerListPingEvent iterator
    [08:12:21 INFO]: [Essentials] Starting Metrics. Opt-out using the global bStats config.
    [08:12:21 INFO]: [Vault][Economy] Essentials Economy hooked.
    [08:12:21 INFO]: [Essentials] Using Vault based permissions (GroupManager)
    [08:12:21 INFO]: [EssentialsProtect] Enabling EssentialsProtect v2.0.1-bSNAPSHOT
    [08:12:21 INFO]: [EssentialsChat] Enabling EssentialsChat v2.0.1-bSNAPSHOT
    [08:12:21 INFO]: [EssentialsGeoIP] Enabling EssentialsGeoIP v2.0.1-bSNAPSHOT
    [08:12:21 INFO]: [EssentialsGeoIP] This product includes GeoLite data created by MaxMind, available from http://www.maxmind.com/.
    [08:12:21 INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.0.1-bSNAPSHOT
    [08:12:21 INFO]: [Shop] Enabling Shop v2.1.0
    [08:12:21 INFO]: [Shop] PlaceholderAPI not found, alternative placeholders will be used.
    [08:12:21 INFO]: [Shop] Citizens not found. NPCs will not be available.
    [08:12:21 INFO]: [SignLink] Enabling SignLink v1.12.2-v3
    [08:12:22 INFO]: [SignLink] SignLink version 1.12.2-v3 enabled! (0.422s)
    [08:12:22 INFO]: [EssentialsSpawn] Enabling EssentialsSpawn v2.0.1-bSNAPSHOT
    [08:12:22 INFO]: [EnjinMinecraftPlugin] Enabling EnjinMinecraftPlugin v3.4.3
    [08:12:22 INFO]: Initializing for the first time.
    [08:12:22 INFO]: Log4j 2 handler detected: com.enjin.common.compatibility.CurrentLog4j2Handler
    [08:12:22 INFO]: [Train_Carts] Enabling Train_Carts v1.12.2-v1
    [08:12:23 INFO]: [Train_Carts] 4 Trains have been loaded in 1 world. (28 Minecarts)
    [08:12:23 INFO]: [Train_Carts] 0 detector rail regions loaded covering 0 blocks
    [08:12:23 INFO]: [Train_Carts] Restoring trains and loading nearby chunks...
    [08:12:24 INFO]: [Train_Carts] SignLink detected, support for arrival signs added!
    [08:12:24 INFO]: [Train_Carts] Train_Carts version 1.12.2-v1 (build: 144) enabled! (1.638s)
    [08:12:24 INFO]: Server permissions file permissions.yml is empty, ignoring it
    [08:12:24 INFO]: Done (9.621s)! For help, type "help" or "?"
    [08:12:24 INFO]: [SimpleTicketManager] Database connection has been kept alive
    [08:12:25 INFO]: [Vault] You are running the latest version
    [08:12:25 INFO]: GroupManager - INFO - Bukkit Permissions Updated!
     
  5. I can't seem to toggle GUI editing.
    When I click on the command block to toggle the GUI thingy it does not toggle at all.
    Only running shop,vault,essentialsx,citizens
     
  6. So I have been using your plugin for my shops for some time now. It's been doing good until I wanted to sell certain items to certain ranks. How do I use the buy permission thingy in the gui? I can't seem to figure out what to put in there to make it so my players can use it.
     
  7. The JAR file this plugin uses is named "Shop.jar", and it allows the creation of shopping/trading pages, which is really cool.
    There's another plugin that also has a JAR named "Shop.jar", and it does simple chest shops.

    I tried to rename one to ShopChests.jar and the other to ShopPages.jar, but my server still only loads one, which I assume is because it thinks that since the "Shop" plugin is loaded, that it doesn't need to load a duplicate "Shop" plugin, regardless of filenames.

    I'm asking you folks for a remedy to my situation. I really need chest-shops for player's creation simplicity, and I would love to use this Shop plugin for my own simplicity of creating an admin shop.
     
  8. Okay... I think part of your problem is that you need PlaceholderAPI. Which can be found here: https://www.spigotmc.org/resources/placeholderapi.6245/

    If you haven't already downloaded this plugin, I know it took me awhile to respond, please tell me if this works.
     
  9. There is another chest shop plugin I find really useful, and cool. It might not be exactly what you had, but it works easily and you can customize the commands to anything you want: https://www.spigotmc.org/resources/shopchest.11431/

    I use it in combination with Shop, and have no problems.
     
  10. After you set the permission needed to use it, I would set the visibility to "permission" so that the only people that can see it are the people that have the permission too. I am not sure if the permissions work just by denying access to players from buying/selling something, BUT, I know for a fact you can hide it from them completely with no issues; making it to where the only people that can see it are the ones with the needed permission.
     
  11. What do you mean by GUI thingy? The command block isn't to toggle the GUI itself, it is meant to toggle the page from being a buy/sell GUI for shop use. Are you talking about the page not turning into a buy/sell GUI? Or not becoming a normal shop? If you are having problems with the page not turning back into a normal shop, I would simply delete it and try again. It might be a pain if you already have a lot of it done, BUT THANKFULLY you can copy it to another shop page using the commands:

    /shop page manage (shop-page you want to copy)
    /shop page copy (shop-page you want to copy it on to)

    AND BOOM! You have copied the shop over!

    However, if you are having problems with the shop page turning INTO a usable GUI, I don't know what to tell you... I notice in your list you didn't have PlaceholderAPI, and I know it *can* work without it, but I highly recommend using it. I do not know if it will fix your problem or not though. Here is a link to it: https://www.spigotmc.org/resources/placeholderapi.6245/
     
  12. It sounds like, to me, you have TWO DIFFERENT shop plugins running at the same time... Or, you already have a Shop configuration file on your server from an earlier time, which would cause your shop to already have items in it. By default, Shop does NOT come with pre-existing shops.

    If you are using ANY shop command and you are going to the SAME PLACE, I would look in your commands.yml to see if you have a shop command defined. If you do, that might be what is causing your problems. Again, this might also be caused by another plugin running alongside Shop, using the same commands. Another thing that might be causing it is how you have Shop configured. By default, it is pretty blank. You have to first create a MAIN shop page, and then define it as the MAIN page in the configuration file.

    I recommend, to fix your problem, to delete the shop file folder (not the JAR) and then restart your server. This will generate the default blank files, and you will have to start from scratch. If you want help doing any of this just pm me, I will walk you through it.
     
  13. I'm hoping to keep the plugin I already have, but I appreciate your assistance.
    I'm still open for suggestions, though.
     
  14. @Lawlzasaurusrex Your server needs to be using Spigot, but you are using Craftbukkit (java -jar craftbukkit.jar). If you want to use this plugin then run your server from the Spigot jar instead of the Craftbukkit one.

    @KubosKube You can try editing the plugin.yml of my plugin and see if that works for you. In the plugin.yml is where the plugin's name and command is at so you can try editing those. You can get to the plugin.yml by opening Shop.jar with something like Winrar or 7zip. Once you find plugin.yml just open it with a text editor.
     
  15. Hey hey! This seems to work wonderfully! I appreciate that!
     
  16. Hello, I have some problems with this plugin and RPGItem plugin. When I'm selling custom items, the shop doesn't show the item price. Is there some fix to this? since when player doesn't have insufficient money they'll not be able to click on the item they wish to buy.
     
  17. So far I love this plugin. It runs amazing, and easy to use! However I can't charge for commands. I tried to make a shop for permissions like /fly but they get the permission for free. It doesn't charge them. And it does not throw any errors. Just curious if I am doing it wrong. I set the item to a command and then add the command and then add the charge.
     
  18. Yeah, a lot of people have this problem... but it isn't really a problem, it just takes a different method to get it working properly. Here are some quick steps for setting up purchasable commands:

    1) Create the item, and change it's function to command.
    2) Set the price you want the command to cost.
    3) Set up the commands. EXAMPLE:

    shop take money (item cost) %player%
    shop send message %player% &aYou purchased (this) command!
    (commands you want to run)

    4) Bask in the awesomeness (NOTE!!! You MUST have the item price set otherwise it will run it REGARDLESS if the player has the money or not!!!)
     
  19. What was the command for the player to sell all of X in his/her inventory?
    I have checked about 10 pages of the discussion but can't find anything
     
  20. Code (Text):

    [20:17:12] [Server thread/ERROR]: Could not pass event InventoryClickEvent to Shop v2.1.0
    org.bukkit.event.EventException: null
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:298) ~[craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:499) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:484) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1820) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.PacketPlayInWindowClick.a(SourceFile:33) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.PacketPlayInWindowClick.a(SourceFile:10) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_121]
        at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_121]
        at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:696) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:371) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:651) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:555) [craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_121]
    Caused by: java.lang.NoSuchMethodError: org.bukkit.event.inventory.InventoryClickEvent.getClickedInventory()Lorg/bukkit/inventory/Inventory;
        at conj.Shop.tools.GUI.InteractEditor(GUI.java:122) ~[?:?]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_121]
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_121]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_121]
        at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_121]
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:296) ~[craftbukkit-1.12.2.jar:git-Bukkit-809c399]
        ... 15 more
     
    Whenever I attempt to add an Item to a shop page I get this error. What is going on?