Premium ShopGUI+ [1.7-1.14] [Paid]

Discussion in 'Resource Discussion' started by brc, Apr 29, 2015.

  1. Hi. I just bought and downloaded the newest version of this plugin.
    I have SilkSpawners, and was coding in the spawer shop. It works.
    The only issue, is that when the spawners are purchased it gives you a non-functional pig spawner (doesn't even spawn pigs).
    any help?
     
  2. Any errors? and can I see your configs
     
  3. anyone can help me ? i found that i cannt use this plugin with /f top by novucs, anyone has a way to solve this ?
     
  4. Whats not working about it?
     
  5. yep, i need only head chicken on chicken spawner on shop :p


     
  6. Think you can add CMI as the Spawner plugin, all of the three SilkSpawner plugins do not work anymore for 1.13+.
     
  7. What Minecraft version are you using?
    Make sure you're using 1.12 IDs for a 1.12 server, 1.13 IDs for a 1.13 server, etc.

    If you share your config via pastebin.com, as well as your console error and your Minecraft version number, I can take a look at it. (If you're running 1.12.x or 1.13.x)
     
  8. Does anyone know of a version that works on 1.13.2?
     
  9. #2630 ajgeiss0702, Apr 9, 2019
    Last edited: Apr 9, 2019
  10. @brc "/iinfo Phantom_membrane" doesnt work. You need to add it. (doesnt work while holding a phantom membrane either.)
     
  11. That's not a command in the plugin. You might be looking for essentials' /itemdb
     
  12. I want to sell potions in the shop. Potions that are drinkable and splashable. How can I do this?

    Edit: I worked it out
     
    #2633 itsaero, Apr 16, 2019
    Last edited: Apr 16, 2019
  13. I keep getting this message when I type /shop —>
    [09:09:48] [Server thread/INFO]: Shop failed to load. Please check the server log for errors. When I check the logs I can find anything... someone please help
     
  14. What is ID for XP bottle?
     
  15. Error occurred while enabling ShopGUIPlus v1.19.1 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/milkbowl/vault/permission/Permission
    at net.brcdev.shopgui.ShopGuiPlugin.setupPermissions(ShopGuiPlugin.java:300) ~[?:?]
    at net.brcdev.shopgui.ShopGuiPlugin.onEnable(ShopGuiPlugin.java:141) ~[?:?]

    can anyone help me. I have a 1.13.2 bukkit server running but shopgui+ isn't working that's the logs
     
  16. using spawner plugin???
    i started to get this issue as well
     
  17. running the latest version of epic spawner is basically disabling the shopgui+ from starting
    see errors from console: https://pastebin.com/uQzNFWaF
     
  18. the only plugin i'm using :/