Solved ShopGUI+ Can't sell spawners.

Discussion in 'Spigot Plugin Help' started by _NovaPvP, Jun 13, 2018.

  1. I run a factions server where spawners are a big part of the economy and one day everything was working fine then I restarted my server and ShopGUI+ gave me the error "/shop [reload]" I didn't know what the problem was so I reinstalled the plugin and made my own config again and the last thing I did was spawners. Everything would work fine until I tried to add a spawner to the shop which worked perfectly before but now just breaks the whole plugin. I don't know what's happening but it's very annoying and I really just don't know how to fix it.

    My Plugins:
    [​IMG]
    https://gyazo.com/bc42249e871c62987a04f27aa8b72334
    Once I add Spawners I do /shop reload and it gives me an internal error then if I open the shop it says that shop with ID spawners not found.
    [​IMG]
    https://gyazo.com/fa14af2452e1e3d7ef82bdb3b2b70670

    shops.yml: https://pastebin.com/qeGdzvgR (Spawners are at the very bottom)
    config.yml: https://pastebin.com/S4uG5yt5

    [13.06 07:30:40 [Server] INFO _NovaPvP issued server command: /shop reload 13.06 07:30:40 [Server] ERROR null 13.06 07:30:40 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'shop' in plugin ShopGUIPlus v1.17.2 13.06 07:30:40 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnection.handleCommand(PlayerConnection.java:1162) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java:997) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_152] 13.06 07:30:40 [Server] INFO at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_152] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:715) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:374) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:654) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:557) [spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_152] 13.06 07:30:40 [Server] INFO Caused by: java.lang.NullPointerException 13.06 07:30:40 [Server] INFO at de.dustplanet.util.SilkUtil.newSpawnerItem(SilkUtil.java:411) ~[?:?] 13.06 07:30:40 [Server] INFO at net.brcdev.shopgui.provider.spawner.SpawnerSilkSpawnersProvider.getSpawnerItem(SpawnerSilkSpawnersProvider.java:25) ~[?:?] 13.06 07:30:40 [Server] INFO at net.brcdev.shopgui.util.ItemUtils.loadItemStackFromConfig(ItemUtils.java:89) ~[?:?] 13.06 07:30:40 [Server] INFO at net.brcdev.shopgui.shop.ShopManager.loadShops(ShopManager.java:179) ~[?:?] 13.06 07:30:40 [Server] INFO at net.brcdev.shopgui.ShopGuiPlugin.load(ShopGuiPlugin.java:194) ~[?:?] 13.06 07:30:40 [Server] INFO at net.brcdev.shopgui.command.CmdShop.onCommand(CmdShop.java:129) ~[?:?] 13.06 07:30:40 [Server] INFO at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot-1.8.8.jar:git-Spigot-e4d4710-e1ebe52] 13.06 07:30:40 [Server] INFO ... 15 more]

    If you have this problem I found out it was SilkSpawners! To fix it change to Version 3.6.7 Of SilkSpawners!
     
    #1 _NovaPvP, Jun 13, 2018
    Last edited: Jun 13, 2018
  2. Rather than screenshot the "An internal error occurred while attempting to perform this command" message, send us the internal error.
    A large stack trace will have appeared in your server console. Put that into code brackets and paste it here. That will allow us to diagnose your problem.
     
  3. I added It :)
     
  4. I used this plugin once and I stoped the sec I relize it wasn't really good, now I make my own shop with deluxemenus, i would recommen using deluxemenu and having a gui with the command /spawnershop and sell spawners that way

    If you asked me i would help you make this Spawnershop GUI with deluxemenus you just have to send me the prices and spawners you want in the shop
     
  5. Sorry I don't really want to switch I'm just looking for a fix for my current problem.
     
  6. have you tried to restart the server?
     
  7. I have Downloaded the plugin and copied your shop.yml and config.yml and i can buy it http://prntscr.com/juhrde

    do you have the lastest version
     
  8. Yes I have 1.17.2 Maybe it's another plugin interfering with ShopGUI+? And I have tried restarting my server.

    EDIT: Just saying I got SpawnerShop after the shop broke so it can't be that messing with ShopGUI+
     
  9. do you have silkspawners installed
     
  10. Yeah I have my full plugin list in the screenshots.
     
  11. it has something to do with ShopGUI because it gives you the prefix of shopgui
     
  12. I know but if it works fine for you and you have the same version and the same config then something else has to be messing with it.
     
  13. delete the files and RESTART your server and then let new file come and then paste your shop.yml and config.yml in the new files

    https://pastebin.com/pYxkfpdX
    https://pastebin.com/0MfyRKu3
     
  14. I've done this about 4 times and switched versions nothing worked I'm fairly sure it's another plugin messing with ShopGUI+
     
  15. try changing the version of the plugin that is 1.8 and see if that works
     

Share This Page