ShopGUI+ Not Working! (1.12.2)

Discussion in 'Spigot Plugin Help' started by Venomous_Creeper, Nov 21, 2018.

  1. Can anyone help me, I'm using 1.12.2 and the latest ShopGUI+ plugin with a default config but when I do /shop it shows: View attachment 386019

    Log:
    Code (Text):
    2:42] [Server thread/INFO]: [ShopGUIPlus] Permissions support enabled.
    [15:12:42] [Server thread/WARN]: [ShopGUIPlus] Spawners plugin not found, spawners won't be supported.
    [15:12:42] [Server thread/ERROR]: Error occurred while enabling ShopGUIPlus v1.19.1 (Is it up to date?)
    java.lang.IllegalArgumentException: null
        at net.brcdev.shopgui.util.ItemUtils.loadItemStackFromConfig(ItemUtils.java:127) ~[?:?]
        at net.brcdev.shopgui.settings.MenuSettings.load(MenuSettings.java:71) ~[?:?]
        at net.brcdev.shopgui.settings.MenuSettings.<init>(MenuSettings.java:22) ~[?:?]
        at net.brcdev.shopgui.settings.MenuWithItemSettings.<init>(MenuWithItemSettings.java:14) ~[?:?]
        at net.brcdev.shopgui.config.Settings.load(Settings.java:368) ~[?:?]
        at net.brcdev.shopgui.config.Settings.setConfig(Settings.java:147) ~[?:?]
        at net.brcdev.shopgui.ShopGuiPlugin.load(ShopGuiPlugin.java:188) ~[?:?]
        at net.brcdev.shopgui.ShopGuiPlugin.onEnable(ShopGuiPlugin.java:146) ~[?:?]
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:381) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:330) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:422) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:383) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:338) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:272) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:545) [spigot-1.12.2.jar:git-Spigot-2086bb0-21d5f75]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
    How can I fix this?

    Thanks!
     
  2. drives_a_ford

    Moderator

    Have you tried contacting the developer of the plugin?
    The plugin page says:
    The dev was last online 6 days ago.
     
  3. Yeah I sent them a PM, I'm asking here as well just in case someone can help me figure it out, because I kind of need it fixed asap.
     
  4. Here's proof I have license to use it:
     
  5. drives_a_ford

    Moderator

    By the look of the stacktrace it probably is a config issue. You could try going through the config tutorial to make sure everything's set up correctly.

    It looks like it's trying to read an item stack from a config file and failing to do so.

    I've not got the plugin nor its config files so I'm afraid I can't be of any further help.
     
  6. I looked at when the last update for 1.12.2 was, and downloaded this version:


    1.18.5-SNAPSHOT Aug 15, 2018

    It works totally fine, although I am worried that I may not be able to download future developments of this plugin because of my 1.12.2 error...

    Hope this helps--at least for now!