Sigh, can't figure out how to get PVP to actually let me smack a player

Discussion in 'Spigot Help' started by nof8, May 24, 2016.

  1. OK so I've got a huge 'spawn' claim. Inside that I've got 'pvp' sub claim.

    I've done this

    First, make sure you have PvP enabled in your server.properties.

    Next, do the command: "/rg flag __global__ pvp deny"
    (This disables PvP everywhere in your world.)

    Then, do "//wand" and select the region that you want PvP enabled in. Once you do that, use the command: "/rg define <area name>".
    (This creates a region that can be flagged with settings.)

    Next you want to use "/rg setpriority <area name> 100".
    (This makes the settings that you add to the region override anything with a lower priority, such as __global__.)

    Finally, do: "/rg flag <area name> pvp allow".
    (This enables PvP in the area you made.)

    I am at a loss...Here is a screen shot of my plugins

    http://imgur.com/atMLom0

    Any files you want me to upload, just tell me what you want to see.

    http://www.filedropper.com/essconfig

    ^Essentials confg file

    http://www.filedropper.com/gpdataconfig

    ^GriefPreventionData config file

    http://www.filedropper.com/permissions_1

    ^server PEX file

    http://www.filedropper.com/server_22

    ^Server properties
     

    Attached Files:

    #1 nof8, May 24, 2016
    Last edited: May 24, 2016
  2. So you are trying to override another region right? What priority is that region set to because that region may have pvp set to deny?

    Thx Pixl
     
  3. ok found it, __global__ is priority 0, the 'pvp' area is priority 100
     
  4. my 'spawn' region that 'pvp' is inside of, has a priority of 50
     
  5. Your "AAC2" looks suspicious to me.