Sign Error Causing Corruption(?)

Discussion in 'Performance Tweaking' started by MCAeolus, Jun 10, 2015.

  1. EDIT: I tried using WorldEdit by selecting a large region (using expand command) and replacing all signs with air. It seems this has worked, and have fixed my problem.

    Hello, Spigot Community!
    My name is Aeolus, and I come here asking of a fix for something I've never seen happen before.

    So let's get the background straight first:
    Basically, a player came on to my server (mc.playome.ga). After going somewhere near spawn that he could build at (and waiting a little while to seem inconspicuous) he asked for all staff to teleport to him. A moderator and I did, after asking him why (said he needed help, and I didn't want to ignore him.) Once teleporting there, he placed down a sign with the words "Right click me to Force Op". I did not click it, and was a bout to remove it, but then the Server Moderator did, and instantly disconnected both of us. In order for us to get on, I had to delete our player files so we would get of of the chunks containing the sign.

    Now, I say this is "corruption", but i'm not completely sure of that, as Minecraft does not regenerate the chunk, and if a player is teleported through the /tpohere command as soon as they try to log on, they can get back from the chunk(s). I believe what's going on is the player(hacker?) placed a sign with illegal character length or similar, which the server/client can't handle.

    Here is the console error:
    Code (Text):
    [13:54:38 ERROR]: io.netty.handler.codec.EncoderException: String too big (was 32788 bytes encoded, max 32767)
    And here is the client disconnect error:
    [​IMG]
    (Disclaimer: French is not my primary language, but I use it for Minecraft.)

    I really haven't seen anything like this before, and am wondering if anyone knows of a good way to handle this (for instance removing the sign, etc.)

    Thanks in advance for any/all help!
    -Aeolus
     
    #1 MCAeolus, Jun 10, 2015
    Last edited: Jun 10, 2015
  2. Rollback your server if you have coreprotect or use a backup
     
  3. Hi, @superbrian12 . Thanks for the reply! I'm afraid when this happened, we found out that our backup plugin stopped working. The newest backup we have is too old for us to use.

    EDIT: I have resolved problem.
     
  4. Would you please share how you fixed this because it has happened to our server twice. We did a server roll back the first time but I do not want to do that again if it can be fixed.
     
  5. I am having this exact problem and I cannot get near enough to delete the sign. I tried removing it with worldedit without success. Does anyone have any other strategies to solve this? It's quite horrible.

    EDIT: It worked after alot of attempts. Can anyone confirm that the sign issue has been fixed in 1.8.7?
     
    #5 janie177, Jun 13, 2015
    Last edited: Jun 13, 2015