Spigot SimpleCore 1.1

A very simple Warp, Spawn, Home plugin which is very lightweight

  1. DrunkTIger submitted a new resource:

    SimpleCore - A very simple Warp, Spawn, Home plugin which is very lightweight

    Read more about this resource...
     
  2. Hi DrunkTIger,

    I just tried to load this plugin but receive the below error messages.

    Server is running Spigot 1.9.4

    Code (Text):
    [13:43:15] [Server thread/ERROR]: Could not load 'plugins/SimpleCore.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: com/github/tobimai/SimpleCore : Unsupported major.minor version 52.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at org.bukkit.craftbukkit.v1_9_R2.CraftServer.loadPlugins(CraftServer.java:296) [spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at net.minecraft.server.v1_9_R2.DedicatedServer.init(DedicatedServer.java:200) [spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at net.minecraft.server.v1_9_R2.MinecraftServer.run(MinecraftServer.java:532) [spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at java.lang.Thread.run(Unknown Source) [?:1.7.0_71]
    Caused by: java.lang.UnsupportedClassVersionError: com/github/tobimai/SimpleCore : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_71]
        at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
        at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
        at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
        at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_71]
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]
        at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_71]
        at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_71]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]
        at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]
        at java.lang.Class.forName0(Native Method) ~[?:1.7.0_71]
        at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_71]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot.jar:git-Spigot-4af49dc-c5e9a16]
        ... 6 more
     
  3. Hmm looks like a problem with the Java Version, which version of Java do you have?
     
  4. I'm not sure as it's hosted through an GSP.

    I'll open a ticket and ask them.
     
  5. Hello PiggyPH,
    in the newest release I compiled the plugin with JRE1.7 and not JRE 1.8, it should work now.
     
  6. Cheers Buddy,

    Once I'm back home I'll give it a whirl and let you know :)