Premium SkillAPI Premium [Paid]

Discussion in 'Resource Discussion' started by Eniripsa96, Aug 18, 2016.

  1. I had a skill called "Dragon's Breath" that did that. I disassembled it to just use fire. Here you go, it kind of works like a flamethrower.
     

    Attached Files:

  2. I have a strange bug I can't figure out. During melee combat there's always a random explosion that happens. I've tried removing all classes and skills and this still happens with skillapi installed.

    Does anyone have a clue why this would happen?
     
  3. https://minecraft.gamepedia.com/Sword#Sweep_attack
     
  4. How do I make a skill?
    Prevent the target from jumping
    Is there any way to do this?
     
    #1404 p82183645, Nov 13, 2017
    Last edited: Nov 13, 2017
  5. Potion mechanic.
    Jump Boost potion effect, Amplifier 128.
     
  6. thank

    How to make arrows shot
    This arrow, will bounce?
    Bouncing on the ground

    If can do it, this is cool
     
  7. Unfortunatly no. There isn't a good way to do that.
    You can however, make an explosion of arrows.
     

    Attached Files:

  8. Bug: per class action bars doesn't work properly, not parsing variables like {health] etc.
     
  9. How can I disable the "You have received X amount of experience from Player/Console" message that comes from the experience command? It's not in the language file.
     
  10. You remove the message in the commands.yml file
     
    • Informative Informative x 1
  11. Thank you a lot.
     
    • Friendly Friendly x 1
  12. What about the ones in lenguage.yml? When I delete it, I still get blank messages.
     
  13. Unfortunatly no, but i do know you can silence the Experience messages in the Experience section of config.yml
     
    • Useful Useful x 1
  14. Where does one configure the experience gained when smelting?
     
  15. It worked. Thank you again.
     
  16. Value Distance Mechanic doesn't work, fix plz!
     
    • Agree Agree x 1
  17. got an error with these lines of my skills:
    - '&e{req:level}&aSeviye: {attr:level}'
    - '&e{req:cost}&aGerekli YP: {attr:cost}'

    level and cost is always 0. Is this a bug or my mistake?
     
  18. User error, worked normally for me.
    I have no idea why it would be 0 in this situation, unless you changed variables, or if you're using an external placeholder.
     
  19. level and cost is 0 on all my skill lores and I dont know why. Do you have any idea?
     
  20. I only have a few ideas, but I think they are all not likely the cause of the issue.

    1. something to do with "show-auto-skills: 'false'"
    -I honestly have no idea what this does, but try changing this.

    2. Language.yml problems.
    -I never touched this file other than removing some exp text messages, however it does have some variable stuff in it. idk why it would effect the skills if its just a language file, but if you changed this, try it with the default file.

    3. Combat type confliction.
    -As someone who has used many different RPG systems, even outside of SkillApi, or anything Minecraft, if you change combat settings in strange ways, it can cause bugs, or just conflicting side effects. I'd look around or change stuff in the combat settings in the config.yml.


    If none of these did anything, well...

    ¯\_(ツ)_/¯

    -Its Probably a new and very specific bug with Skillapi, but just to be sure, check all of your (if you have any) PlaceholderAPI or similar plugin... stuff, maybe there's a confliction somewhere. Try also doing a reset of all of your skillapi settings to default (make sure you back up your old stuff lol), to see if the issue still occurs.


    I've had some similar strange issues like this before several months ago, and all I did was reset everything to default and redid the config files.
     
    • Friendly Friendly x 1

Share This Page