Skyblock Version

Discussion in 'Server & Community Management' started by DavidTheKID1985, Mar 23, 2020.

  1. Should I have my skyblock server at 1.12.2 or should it be 1.14+?
     
  2. Gianluca

    Gianluca Retired Resource Staff
    Retired Patron

    If your plugins support 1.14+, there's no reason to not use it, especially for SkyBlock, which would be even more fun with new blocks/mechanics
     
  3. Choco

    Moderator

    1.14 shouldn't even be an option. Nor should 1.12. Your server should be on 1.15. Period.
     
    • Optimistic Optimistic x 2
    • Like Like x 1
    • Agree Agree x 1