Small question about JRE and JDK

Discussion in 'Spigot Plugin Help' started by Nighterance, Apr 15, 2017.

  1. So I have a plugin, everything works fine. When I gave it to my friend, that is using java that is not 1.8 version,
    plugin does not work. When he updated it, it worked. I know, that it worked for him, but It is not essential so any person can install it, despite java version they have.

    Is it possible to do? Sorry, could not describe this problem as much as needed.
     
  2. If you want to support lower versions then compile it in that version.
    E.g. compiling in version 1.7 allows people on 1.7+ to use it.
    However everyone should be on java 8 by now. If not, tell them to — it's their fault not yours for being outdated
     
  3. So basically you reccomend me to leave as it is, right?