Snake Minigame not work Lib`sDisguise too

Discussion in 'Spigot Plugin Help' started by TheSkydust, May 14, 2015.

  1. Hi. i try put a Snake minigame on my server... its my first time making a server and i need help i have errors with some plugins. Snake Minigame in the console say me that: (lib`sDisguises dosent work too)

    Error occurred while enabling SnakeChallenge v1.0 (Is it up to date?)
    java.lang.NoClassDefFoundError: net/minecraft/server/v1_7_R1/World
    at com.comze_instancelabs.snakechallenge.Main.onEnable(Main.java:188) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:250) ~[spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:324) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.loadPlugin(CraftServer.java:468) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.enablePlugins(CraftServer.java:387) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.reload(CraftServer.java:823) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.Bukkit.reload(Bukkit.java:286) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:24) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:180) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.craftbukkit.v1_7_R3.CraftServer.dispatchCommand(CraftServer.java:724) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.PlayerConnection.handleCommand(PlayerConnection.java:1007) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.PlayerConnection.a(PlayerConnection.java:835) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.PacketPlayInChat.a(PacketPlayInChat.java:29) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.PacketPlayInChat.handle(PacketPlayInChat.java:63) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.NetworkManager.a(NetworkManager.java:190) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.ServerConnection.c(ServerConnection.java:82) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.MinecraftServer.v(MinecraftServer.java:715) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.DedicatedServer.v(DedicatedServer.java:283) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.MinecraftServer.u(MinecraftServer.java:583) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:488) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_7_R1.World
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:67) ~[spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:62) ~[spigot-1.7.9-R0.2-1543-Pach.jar:git-Spigot-unknown]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_79]
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_79]
    ... 22 more
     
  2. According to this error code
    "at com.comze_instancelabs.snakechallenge.Main.onEnable(Main.java:188) ~[?:?]"
    there is an error in the Main package on line 188.
     
  3. i have my server in a Ubuntu host... how i can solve this error?
     
  4. well are there any mods on this server or plugins? Because with an error in the mod or plugin it can show an error code like that