[Solved] Cant Get TnT to work

Discussion in 'Spigot Plugin Help' started by JuniorCraft, May 17, 2015.

  1. So for some hours now i have been trying to Enable tnt but everything failing could anyone give me some suggestions here are my plugins
    http://imgur.com/zqv4Nsn
     
  2. Debug. Delete every plugin one by one until you find the issue, or use a method similar to a binary search in which you delete half of your plugins, find which half is causing the issue, delete half of that half, etc.
     
    • Useful Useful x 1
  3. Ok, thanks i will try this
     
  4. In your essentials folder you have in config "block use", and "block place" or something like that. Make sure tnt id is not on any list of these.
     
  5. Disable /stoplag
    I think it is /stoplag -c
     
  6. So i have tried all these other suggestions, but the first one had worked best but im still not sure which plugin it is exactly but i know that it is either Multiverse or a plugin that require's multiverse.
     
  7. It could be Factions. Some versions of Factions have TnT disabled by default.
     
  8. Nop looks like it does not have anything to do with tnt being disabled in my Factions Configs, in fact there is nothing to do with tnt or explosions in the configs except for with factions perms and flags
     
  9. It will probably be factions. Most of the configuration for the Factions plugin is in the main directory for your sever (where the world and plugins folder is) in the "mstore" directory. It will likely be the 'explosions.json' file inside that, and the 'standard' node should be set to 'true'.
     
  10. In essentials under build section look for black list, and remove the tnt id from it.
     
  11. My only Factions configs are in Mstore so it is Defiantly not factions
    And i do not have anything blacklisted in my essentials configs
    im currently still using the first method every now and then when i have the time :)
     
  12. Fixed the bug :D turned out the issue was to do with world guard, the way that i fixed it was by going through my start up log and searching for "TNT" and "Explosions" then i found that world guard had TNT turned off