[Solved]EssentialsChat+Groupmanager - Spigot

Discussion in 'Spigot Help' started by Leo_0, May 16, 2015.

  1. So, Since bukkit haven't updated their essentials version i downloaded the spigot one along with groupmanager, I'm having a problem.
    Whenever I add myself to a random group (after i've done all the group formats on the config file) Prefix and the other stuff would not show up, I went to Mibbit Essentials, Since this is the "unofficial version" they would not like to help me so i understood i should go to spigot since it's spigot's version.
    If needed, Here's the pastebin of my essentials config file:
    http://pastebin.com/Auh1vDCJ

    Thanks in advance!
    - Leo
     
  2. That's a pastebin of the server log. Can you post one of the essentials config?
     
  3. Ooops :p accident.
    Also i just noticed it deleted the group formats i added, I'm not sure why and im pretty sure i did save multiple times...
     
  4. Ok, it now seems to have saved the config file and YET not working.
    http://pastebin.com/KvSuAWUT
     
  5. Try changing the line "#add-prefix-suffix: false" to "add-prefix-suffix: true". So basically uncomment the line and change it to true. Also while your at it uncomment "change-playerlist" and make sure it's set to true.
     
  6. http://pastebin.com/Q6ETdMh6
    still no :/
     
  7. Do you have the essentialschat.jar in your plugins folder?
     
  8. Woops...
    Ill add it and see if it works.
     
  9. The Dev team abandons the
    Groupmanager in 1.8.3 ..it is true but sad.
    Other persmission plugin is so hard to use it.
    Groupmanager is more user-friendly, it is very disappointed
     
  10. Whenever i restart/reload the sever to make it work it would just reset the file.
     
  11. you mean i need to use the spigot version? because im using the bukkit one
     
  12. but i think it's still suppose to work? because i see many servers that use it while it still works there.
     
  13. It is work but the plugin still have bugs in 1.8.3 version.
    Run about 2 -3 hour or the player change to other world , then all some of player will be reseted to default group
     
  14. I see that in the essentials config there is:
    Code (Text):
    format: '<{DISPLAYNAME}> {MESSAGE}'
    #format: '&7[{GROUP}]&r {DISPLAYNAME}&7:&r {MESSAGE}'
    group-formats
    Default: ' &a{DISPLAYNAME}&7:&8 {MESSAGE}'
    Moderator: ' &f[&9Mod]&a {DISPLAYNAME}&7:&b {MESSAGE}'
    Admin: ' &f[&cAdmin&f]&e&l {DISPLAYNAME}&7:&b {MESSAGE}'
    Owner: ' &f[Owner]&r {DISPLAYNAME}&7:&c {MESSAGE}
    The problem with the chat here is that you have the format + the group formats unhashed.
    Change
    Code (Text):
    format: '<{DISPLAYNAME}> {MESSAGE}'
    with
    Code (Text):
    #format: '<{DISPLAYNAME}> {MESSGAGE}',
    That should leave you with the group chat colors and prefix's you set.

    Make sure that the groups ARE EXACTLY THE SAME AS IN THE CONFIG as they are CaSe SeNsItIvE.

    Another recommendation is to download Spigot, as it is almost 2x faster than bukkit and has many more features, including the ability to run bukkit plugins.
    Simply do this by de-compiling a BuildTools.jar with Git bash (more information here: http://www.spigotmc.org/wiki/buildtools/)
    Or, instead of getting all the recommended versions of that (and avoiding the 30minute decompile wait), download Spigot from Yive's mirrors. (http://tcpr.ca/spigot)
    If you want an EVEN FASTER version of Spigot, use PaperSpigot (http://tcpr.ca/paperspigot) although there may be some bugs.

    Good day
     
  15. Thanks, I removed the hashtag and it worked.
    I downloaded the spigot jar and everything works now:)
    Edit: changed thread prefix to solved.
     
    • Agree Agree x 1
  16. Haha, No problemo :p
     
    • Like Like x 1