[SOLVED]Help with building the servers.

Discussion in 'Spigot Help' started by rtester, May 8, 2015.

  1. I spent a few hours trying to find if anyone else had this issue. this is the last part of the log where the build stopped.
    HEAD is now at d6f332e CraftBukkit $ Fri May 08 07:57:29 PDT 2015
    Cloning into 'Spigot-Server'...
    done.
    Resetting Spigot-Server to CraftBukkit...
    error: Could not remove config section 'remote.upstream'
    HEAD is now at d6f332e CraftBukkit $ Fri May 08 07:57:29 PDT 2015
    Applying patches to Spigot-Server...
    Resolve operation not in progress, we are not resuming.
    Applying: POM Changes
    Applying: mc-dev imports
    Applying: Skeleton API Implementations
    Applying: Obfuscation Helpers
    fatal: sha1 information is lacking or useless (src/main/java/net/minecraft/server/MinecraftServer.java).
    Repository lacks necessary blobs to fall back on 3-way merge.
    Cannot fall back to three-way merge.
    Patch failed at 0004 Obfuscation Helpers
    The copy of the patch that failed is found in:
    d:/spigot/Spigot/Spigot-Server/.git/rebase-apply/patch
    When you have resolved this problem, run "git am --continue".
    If you prefer to skip this patch, run "git am --skip" instead.
    To restore the original branch and stop patching, run "git am --abort".
    Something did not apply cleanly to Spigot-Server.Error compiling Spigot, are you running this jar via msysgit?

    Please review above details and finish the apply then
    save the changes with rebuildPatches.sh
    java.lang.RuntimeException: Error running command, return status !=0: [bash, applyPatches.sh]
    at org.spigotmc.builder.Builder.runProcess(Builder.java:492)
    at org.spigotmc.builder.Builder.main(Builder.java:389)

    and i typed in this "git am --skip" into the bash window without the quotes and I get the following message
    fatal: Not a git repository (or any of the parent directories): .git

    I do not know what to do to build the server files. I forgot to mention I was trying to build build #36 and I am running a windows 7 professional 64 bit box with java 8 and the java 8 jdk.
     
  2. Add your own directory for it to run, and also, you should change build to spigot, its easier i find to use
     
  3. I had it in a directory called BuildTools, but I had to delete and rebuild like 10 times for it to build correctly without erroring out, my guess is that it couldn't connect to the repository it needed to at the time I was trying to build it. Also what does changing my build to spigot have to do with building spigot in the first place. That is what I am using now that I was able to get the build to compile correctly.