[SOLVED] JRE 8.0 Memory Allocation Error

Discussion in 'Systems Administration' started by Sleepyflea, Aug 3, 2019.

Thread Status:
Not open for further replies.
  1. Error: Native memory allocation (mmap) failed to map 12288 bytes for committing reserved memory.
    Yes all of my servers have plenty of ram. And i am using only about 80% of my system available memory.
    - CompressedOops are enabled
    - I have enabled unlimited Core dumping

    My general startup line is: java -Xmx10G -jar -XX:+UseG1GC server.jar nogui

    Im beyond lost. Never ran into this issue in 10 years of running minecraft servers.

    Code (Java):
    #
    # There is insufficient memory for the Java Runtime Environment to continue.
    # Native memory allocation (mmap) failed to map 12288 bytes for committing reserved memory.
    # Possible reasons:
    #   The system is out of physical RAM or swap space
    #   The process is running with CompressedOops enabled, and the Java Heap may be blocking the growth of the native heap
    # Possible solutions:
    #   Reduce memory load on the system
    #   Increase physical memory or swap space
    #   Check if swap backing store is full
    #   Decrease Java heap size (-Xmx/-Xms)
    #   Decrease number of Java threads
    #   Decrease Java thread stack sizes (-Xss)
    #   Set larger code cache with -XX:ReservedCodeCacheSize=
    #   JVM is running with Unscaled Compressed Oops mode in which the Java heap is
    #     placed in the first 4GB address space. The Java Heap base address is the
    #     maximum limit for the native heap growth. Please use -XX:HeapBaseMinAddress
    #     to set the Java Heap base and to place the Java Heap above 4GB virtual address.
    # This output file may be truncated or incomplete.
    #
    #  Out of Memory Error (os_linux.cpp:2766), pid=5363, tid=0x00007f19771db700
    #
    # JRE version: OpenJDK Runtime Environment (8.0_212-b04) (build 1.8.0_212-b04)
    # Java VM: OpenJDK 64-Bit Server VM (25.212-b04 mixed mode linux-amd64 compressed oops)
    #
     
  2. Could be worth to try and disable compressed oops.
     
  3. Which panel do you use, or no panel? If you use pterodactyl, ptero uses docker.
     
  4. Theres no need for a panel if you know what your doing. IMO.
    I use putty and my keyboard.
     
  5. Doing that resulted in 1 less error on the crash log.
    But now it is still crashing saying out of memory every hour or so.
     
  6. md_5

    Administrator Developer

    Its literally what it says.
    Your server does not have enough memory available.
    Decrease Xmx.
     
  7. Thats not the issue if you read that. I have 16 gigs in my server and im only using like 12?
    I fixed it by doing something simple i should have thought of from the start. Down below is how
     
  8. Issue has been fixed by uninstalling Java 8 and reinstalling java.
    Auto updates got disabled somehow. Possibly 2 java versions corrupting eachother.
     
Thread Status:
Not open for further replies.