[SOLVED] [Linux] [Ubuntu] Multicraft File Permissions

Discussion in 'Systems Administration' started by MatthewGraphics, Jul 26, 2016.

Thread Status:
Not open for further replies.
  1. So everytime I start one of my Multicraft servers I get this error, I tried to fix it by writing the file permissions to 777, 775, 755 but none of them work. I am not sure why I am getting this error but it is either saying cannot write to server.properties, commands.yml, eula.txt. And the server keeps crashing and rebooting.

    If anyone can help please add me on skype preferably and when you add me tell my why so I know that you are trying to help me.

    http://prntscr.com/bxvzw0
     
  2. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Never chmod them all to 777. You need to chown the file/directories to the proper owner.
     
  3. The way multicraft has it is each server is has a different user. Should I change this? And what should I chmod them to?
     
  4. What I did is I get the /home/minecraft/multicraft server folder to 755 and then I re-did the chown permissions with the user per server (mc1, mc2, etc) using
    Code (Text):
    chown mc1 -R /home/minecraft/multicraft/servers/server1
    And the 755

    Code (Text):
    chmod 755 -R /home/minecraft/multicraft/servers
     
Thread Status:
Not open for further replies.