[Solved] My server suddenly falls

Discussion in 'Performance Tweaking' started by AlansS53, Jul 13, 2018.

  1. * Hello everyone! Recently I had had drops in the tps of my server and the truth is that I have not found anything, this only happens sometimes, I had up to 45 players connected without problem, and these falls tend to occur with only 20-30
    * I downloaded version 1.8.8 with the timmings tool to check more thoroughly what happens.
    Apparently what causes the falls are the terminals save-world and save-all but I do not understand much about this ...
    * Could someone check the timmings of my server to help me? If the problem is the auto-save of worlds how could I solve it?
    Thanks in advance and sorry for my bad english.

    Timings: https://timings.spigotmc.org/?url=xesumuyusa
     
    #1 AlansS53, Jul 13, 2018
    Last edited: Jul 13, 2018
  2. Timings seems fine, could it be a memory leak? Hoy much ram has the server?
     
  3. So save-world and save-all are not a problem?
    I have 3GB of RAM, 42 plugins and 6 worlds, but when I use commands like / gc or / lagg check the server only uses half of ram.
    During the startup the tps also decrease, until reaching about 13.
     
  4. Try to look for a better start script and also preload your chunks
     
  5. But how could I change the startup script of my host?
     
  6. U cant.
    Buy a VPS or use another host xd.
     
  7. Are you using Multicraft?
     
  8. What, hosting provider they may not be off best use some hosting services get real bad locations set to their regions that cause a lot of tps lag also their systems dedicated ram usages etc... Id suggest possibly finding a better host?
     
  9. What, version of woldguard are you also using that's also using the most server memory. ?
     
  10. Yes

    * My hosting is Withernode in Montreal, Canada.
    * Apparently the version of worldguard was a snapshoot so I placed the official version, I'll see if that improves anything.
    * I have placed some commands to run when the server lowers its tps and the results are the following:
    --------------------------------------------------------------------------------------------------------------
    [06:55:05] [Server thread / INFO]: TPS from last 1m, 5m, 15m: 18.23, 19.57, 19.81
    --------------------------------------------------------------------------------------------------------------
    [06:55:05] [Server thread / INFO]: * (Server Status) *
    [06:55:05] [Server thread / INFO]: Items on the ground: 65
    [06:55:05] [Server thread / INFO]: Mobs alive: 282
    [06:55:05] [Server thread / INFO]: Frienly-Mobs alive: 315
    [06:55:05] [Server thread / INFO]: Players alive: 11
    [06:55:05] [Server thread / INFO]: Chunks loaded: 2930
    [06:55:05] [Server thread / INFO]: Active hoppers: 12
    [06:55:05] [Server thread / INFO]: Idle hoppers: 60
    [06:55:05] [Server thread / INFO]: Active mob spawners: 21
    [06:55:05] [Server thread / INFO]: Current TPS: 16.0
    [06:55:05] [Server thread / INFO]: RAM Usage: 1763 / 2995MB
    [06:55:05] [Server thread / INFO]: * *
    --------------------------------------------------------------------------------------------------------------
    [06:55:05] [Server thread / INFO]: CONSOLE issued server command: / gc
    [06:55:05] [Server thread / INFO]: [+] Time on: 9 hours 50 minutes 32 seconds
    [06:55:05] [Server thread / INFO]: * Ticks per second: 17.11
    [06:55:05] [Server thread / INFO]: * Maximum memory: 2,995 MB.
    [06:55:05] [Server thread / INFO]: * Memory allocated: 2,995 MB.
    [06:55:05] [Server thread / INFO]: * Free memory: 1,231 MB.
    [06:55:05] [Server thread / INFO]: * World "world": 228 chunks, 13 entities, 300 tiles.
    [06:55:05] [Server thread / INFO]: * The End "world_the_end": 0 chunks, 0 entities, 0 tiles.
    [06:55:05] [Server thread / INFO]: * Nether "world_nether": 0 chunks, 0 entities, 0 tiles.
    [06:55:05] [Server thread / INFO]: * World "WorldRecurso": 1,095 chunks, 424 entities, 77 tiles.
    [06:55:05] [Server thread / INFO]: * World "Plots": 901 chunks, 63 entities, 813 tiles.
    [06:55:05] [Server thread / INFO]: * World "MundoLibre": 706 chunks, 274 entities, 90 tiles.
    --------------------------------------------------------------------------------------------------------------
    [06:55:05] [Server thread / INFO]: [ClearLag] 520 chunks have been unloaded!
    --------------------------------------------------------------------------------------------------------------
     
    #10 AlansS53, Jul 14, 2018
    Last edited: Jul 14, 2018
  11. It's your multiverse core It looks like Its overloading Its self and might have a corrupted world that's causing your server to run on low ram and then It causes crashed or unsaved data?
     
  12. I really don't recommend using multiverse... most servers have no use for it and it is riddled with bugs everywhere.
     
  13. correct here In your error listing Its multiverse you have a world that's trying to allocate players to spawn but It seems to be removed.
     
  14. You should uninstall it, and then reinstall iit(aka delete the folder) just to make surre.
     
    • Agree Agree x 1
  15. Can Highly agree as Your config Is trying to pull a world that's not loading correctly due to corrupted data.