[solved] Permission Problem with the plugin quester

Discussion in 'Spigot Plugin Help' started by GwueFi, May 24, 2015.

  1. Hi all

    Its me again.. :-/

    I have a little problem with the plugin Quester.
    I have to be op if i want to start a quest. If im in game as a guest (default role) then i do not have the permissions.

    This is my yml:
    Code (Text):
    ---
    groups:
      Admin:
        build: true
        inheritance:
          - Mod
          - VIP
          - Member
          - Guest
        options:
          default: false
          prefix: "&9[&bAdmin&9]&f "
        permissions:
          - essentials.gamemode
          - essentials.give
          - essentials.god
          - quests.quest
          - quests.questinfo
          - quests.quests
          - quests.take
          - quests.quit
      Guest:
        build: false
        options:
          default: true
          prefix: "[Guest] "
        permissions:
          - essentials.help
          - essentials.rules
          - essentials.motd
          - essentials.spawn
          - essentials.warp
          - essentials.warp.work
          - essentials.sethome
          - essentials.home
          - modifyworld.chat
          - islandworld.island.create
          - islandworld.island.delete
          - islandworld.island.spawn
          - islandworld.island.home
          - islandworld.island.sethome
          - islandworld.island.delhome
          - islandworld.island.fixhome
          - islandworld.create.normal
          - quests.quest
          - quests.questinfo
          - quests.quests
          - quests.take
          - quests.quit
      Member:
        build: true
        options:
          default: false
          prefix: "&2[&aMember&2]&7 "
        permissions:
          - essentials.help
          - essentials.rules
          - essentials.motd
          - essentials.afk
          - essentials.back
          - essentials.back.ondeath
          - essentials.depth
          - essentials.delhome
          - essentials.help
          - essentials.home
          - essentials.kit
          - essentials.kit.tools
          - essentials.list
          - essentials.mail
          - essentials.mail.send
          - essentials.me
          - essentials.motd
          - essentials.msg
          - essentials.ping
          - essentials.r
          - essentials.rules
          - essentials.seen
          - essentials.sethome
          - essentials.signs.use.disposal
          - essentials.spawn
          - essentials.suicide
          - essentials.tpa
          - essentials.tpaccept
          - essentials.tpahere
          - essentials.tpdeny
          - quests.quest
          - quests.questinfo
          - quests.quests
          - quests.take
          - quests.quit
      Mod:
        build: true
        inheritance:
          - VIP
          - Member
          - Guest
        options:
          default: false
          prefix: "&1[&9Mod&1]&f "
        permissions:
          - essentials.sethome.multiple.staff
          - essentials.helpop
          - essentials.home.others
          - essentials.nick
          - essentials.warp
          - essentials.warp.list
          - quests.quest
          - quests.questinfo
          - quests.quests
          - quests.take
          - quests.quit
      Owner:
        build: true
        options:
          default: false
          prefix: "&6[&4Owner&6]&f "
        permissions:
          - "*"
      VIP:
        build: true
        inheritance:
          - Guest
          - Member
        options:
          default: false
          prefix: "&6[&eVIP&6]&7 "
        permissions:
          - essentials.help
          - essentials.rules
          - essentials.motd
          - quests.quest
          - quests.questinfo
          - quests.quests
          - quests.take
          - quests.quit
    schema-version: 1
    users:
      exampleminecraftname:
        group:
          - Owner
      exampleminecraftname2:
        group:
          - Admin
     
    What I have done wrong?

    Thank you for your help :)
    GwueFi
     
    #1 GwueFi, May 24, 2015
    Last edited: May 24, 2015
  2. Are you sure you have the correct parameters on permissions?
     
  3. Check your configuration with the YMAL Parser. Should tell you the errors.
     
  4. @Rendadus:
    Thank you.. you solved it! :D I was obviously too tired to concentrate me yesterday.

    Thank you very much! :)