[Solved] WG entry flag not keeping players out

Discussion in 'Spigot Plugin Help' started by invincible64, Jul 2, 2015.

  1. Hi, i've been trying to create a region that only its members can enter, and from every tutorial I've seen its as simple as typing /rg flag region entry deny -g nonmembers. For some reason, when I try doing that exact same thing it does nothing to prevent players from entering the region. I've tried deopping myself, messing with the config, updating worldguard, and nothing seems to work. I have a hunch that there's a plugin conflict going on, and if someone could help me spot it that'd be great. Here's a list of my plugins: http://pastebin.com/pFwu0fiK
     
  2. An example would be if a had a group called Admin and I wanted this group to be able to access a region called banana, I would type:

    /region define banana
    /region flag banana entry deny
    /region addmember banana g:Admin
    /region flag banana entry -g nonmembers

    Then I'd add the permission node "group.Admin" to the Admin group in your permissions plugin's config.
     
  3. I know how to do that, but I watched a youtube tutorial where the guy simply set it to deny and it worked. What im saying is that the entry deny doesn't do anything to keep people out of the region.
     
  4. Somebody help please!
     
  5. Try something simple like this: http://pastebin.com/gtMYbuMZ.

    If that doesn't work I would think that it will be a conflicting plugin, or an error with your permissions.

    If you think its a conflicting plugin try to delete 10 plugins at a time, test if the region works, if it doesn't, re add the deleted plugins to the server and delete another 10 and so on so you can narrow down which plugin may be conflicting.
     
  6. Thanks but the flag was successfully added to the region, and I did check the perms. I was hoping someone already knew of a plugin conflict and could point it out to me.
     
  7. Seeing as no one seems to know of the plugin conflict, could I go over your perms to see if you missed something?
     
  8. Did you perhaps disable the PlayerMoveEvent in your WG config?
     
  9. That was disabled but I enabled it, reloaded and nothing changed.
     
  10. Nevermind, I had enabled PlayerMoveEvent in the config and reloaded, but I guess I had to RESTART to get it to work. Thank you so much!!!
     
    • Like Like x 1