1.12.2 Solved

Discussion in 'Spigot Plugin Development' started by SwenNoort, Mar 30, 2020.

Thread Status:
Not open for further replies.
  1. Hey guys, i'm trying to make a nexus plugin. Its somethink like a plugin that create's a block and you need to break it. But there is another team that wants to kill you. You probably know what i mean XD. I want to place wool with command so i can give it some MetaData or something because when i place or break any wool the plugin thinks its a nexus. So i tryed to make a command that places wool but.. there is a error on setType.

    [​IMG]

    Sorry for my english :\
     
  2. What is the error if you go over setType?
     
  3. You have imported `net.minecraft.server.v1_12_R1.Material` instead of `org.bukkit.Material` - there is a type mismatch. Change your import at the top of your file. Also, prior to setting a block's type - check if the block you've selected is null. This will prevent errors down the line.
     
    • Informative Informative x 1
  4. You imported the wrong Material.
    Remove it from the top, and import org.bukkit.material ;)
     
    • Like Like x 1
  5. OMG XD this is stupid that i didn't see this thanks m8 <3
     
    • Like Like x 2
  6. Be sure to mark your thread as solved, my pleasure.
    Have fun developing!
     
Thread Status:
Not open for further replies.