Something is terribly wrong [Timings included]

Discussion in 'Performance Tweaking' started by Mega9, Jul 8, 2015.

  1. Today we had an opening of the server, of course no one is a professional nor a java coder therefore we hoped for the best, and got the worst.

    Within first minute of server opening we had around 70 players, everything went fine for a couple of minutes until everything started lagging so bad.

    Just by looking at the timings I know something is bad and it shouldn't be consuming so much time to process something, but still I do not have enough knowledge to fully understand the readings - and that's where you, good souls, come in :)

    http://timings.aikar.co/?url=11842786

    (Timings were taken at ~20 connected players)
     
  2. dtm

    dtm Retired Moderator
    Retired Supporter

    17 TPS with 70 online isn't terrible at all.
    Just make sure you limit the amount of entities (ClearLagg?)
    Also, it could be that your players are exploring the world a lot, which will be relatively intensive, loading new terrain.
    You could use WorldBorder to pre-generate the world?
     
  3. Thank you for your answer.

    World border is set to 20k at the moment.
    ClearLagg is running every 2 minutes.
    Could it be that our host is 'sharing' the hardware [overselling]?
     
  4. dtm

    dtm Retired Moderator
    Retired Supporter

    That last one is a possibility. You could always look into dedicated hosting (If it's with-in budget).
    If not, check that you're players aren't generating a lot of new terrain.
     
  5. That could actually be possible. I'll have to wait this out and see if it gets better through next few days (when players become more stationary)

    Thank you for your help!