Premium [Source] [WetSponge] EggWars - MultiArena & Bungee, MultiLang, Fully Customizable [Paid]

Discussion in 'Resource Discussion' started by Degoos, Sep 16, 2017.

  1. Could you please post the whole error log? It may be a chained error caused by other thing.
    Also yep, we have updated the sounds to be "nicer", anyway you can change them but take into account that those are not 1.9+ sounds but WetSponge Sounds, which are going to be changed by their 1.8 version.
     
  2. Okey. So sounds are ok right?
    Full log? You mean in log file?
    I I think that's all. I'll check it later.
    I've been trying to use this plugin since it was release :(
     
  3. Hi!

    Yes, we need the log file.

    About the songs, we're using a translator for 1.8 that replaces 1.9 sounds to similar 1.8 sounds.
    You can find all the sounds here: https://gitlab.com/degoos/WetSponge.../java/com/degoos/wetsponge/sound/WSSound.java
     
  4. Degoos updated [XMas%Disc][WetSponge] EggWars - MultiArena & Bungee, MultiLang, Fully Customizable with a new update entry:

    Bugfixing

    Read the rest of this update entry...
     
  5. This is all i could find related to eggwars and wetsponge plugin. There is nothing else in log file.
    Help :(
    Code (Text):
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading WetSponge...[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mUsing version [0;32;1mSPIGOT MINECRAFT_OLD[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading entities.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading Spigot listeners.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading common.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading database drivers.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mWetSponge implements JOOQ, so developers can use it to handle connections to databases.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading injectors.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading messages.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading MultiInventory API.[m
    [10:34:27] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading plugins.[m
    [10:34:28] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading plugin [0;33;1mLanguages [0;31;1m1.4[0;36;1m.[m
    [10:34:29] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading plugin [0;33;1mEggWars [0;31;1m1.5[0;36;1m.[m
    [10:34:29] [Server thread/WARN]: SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
    [10:34:29] [Server thread/WARN]: SLF4J: Defaulting to no-operation (NOP) logger implementation
    [10:34:29] [Server thread/WARN]: SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
    [10:34:30] [Server thread/INFO]: [0;33;1m[EggWars -> [0;36;1mInfo[0;33;1m] [0;36;1mThere was a missing table in your database, let's fix it (don't worry, you won't lose any of your current data)[m
    [10:34:32] [Server thread/INFO]: [0;33;1m[EggWars -> [0;36;1mInfo[0;33;1m] [0;36;1mEggWars couldn't find any structure. Saving a default one in cageStructures.yml...[m
    [10:34:32] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;36;1mInfo[0;33;1m] [0;36;1mLoading WetSponge commands.[m
    [10:34:32] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;32;1mDone[0;33;1m] [0;32;1mWetSponge has been loaded in [0;31;1m5.449[0;32;1m seconds![m
    [10:39:33] [Thread-12/INFO]: UUID of player AlonsoAliaga is *****
    [10:39:33] [Server thread/INFO]: AlonsoAliaga[/*****] logged in with entity id 470 at ([world]-21.959220209494756, 67.0, 255.84494111000132)
    [10:39:52] [Server thread/INFO]: AlonsoAliaga issued server command: /pl
    [10:39:55] [Server thread/INFO]: AlonsoAliaga issued server command: /ew
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m--------------------------------------------[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1mAn error has occurred while WetSponge was parsing the event Spigot-PlayerCommandPreprocessEvent![m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1mType: [0;33;1mjava.lang.NullPointerException[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1mDescription: [0;33;1m-[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1mCause: [0;33;1m-[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1mStackTrace: [m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.util.Optional.[0;35;1morElseThrow[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- com.degoos.eggwars.command.GeneralCommand.[0;35;1mexecuteCommand[0;32;1m ([0;33;1mGeneralCommand.java[0;32;1m:[0;33;1m51[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- com.degoos.wetsponge.listener.spigot.SpigotSendCommandListener.[0;35;1mlambda$onCommand$0[0;32;1m ([0;33;1mSpigotSendCommandListener.java[0;32;1m:[0;33;1m45[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.util.Optional.[0;35;1mifPresent[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- com.degoos.wetsponge.listener.spigot.SpigotSendCommandListener.[0;35;1monCommand[0;32;1m ([0;33;1mSpigotSendCommandListener.java[0;32;1m:[0;33;1m42[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- sun.reflect.NativeMethodAccessorImpl.[0;35;1minvoke0[0;32;1m ([0;33;1mNative method[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- sun.reflect.NativeMethodAccessorImpl.[0;35;1minvoke[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- sun.reflect.DelegatingMethodAccessorImpl.[0;35;1minvoke[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.lang.reflect.Method.[0;35;1minvoke[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- org.bukkit.plugin.java.JavaPluginLoader$1.[0;35;1mexecute[0;32;1m ([0;33;1mJavaPluginLoader.java[0;32;1m:[0;33;1m306[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- org.bukkit.plugin.RegisteredListener.[0;35;1mcallEvent[0;32;1m ([0;33;1mRegisteredListener.java[0;32;1m:[0;33;1m62[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- org.bukkit.plugin.SimplePluginManager.[0;35;1mfireEvent[0;32;1m ([0;33;1mSimplePluginManager.java[0;32;1m:[0;33;1m502[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- org.bukkit.plugin.SimplePluginManager.[0;35;1mcallEvent[0;32;1m ([0;33;1mSimplePluginManager.java[0;32;1m:[0;33;1m487[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.PlayerConnection.[0;35;1mhandleCommand[0;32;1m ([0;33;1mPlayerConnection.java[0;32;1m:[0;33;1m1154[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.PlayerConnection.[0;35;1ma[0;32;1m ([0;33;1mPlayerConnection.java[0;32;1m:[0;33;1m997[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.PacketPlayInChat.[0;35;1ma[0;32;1m ([0;33;1mPacketPlayInChat.java[0;32;1m:[0;33;1m45[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.PacketPlayInChat.[0;35;1ma[0;32;1m ([0;33;1mPacketPlayInChat.java[0;32;1m:[0;33;1m1[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.[0;35;1mrun[0;32;1m ([0;33;1mSourceFile[0;32;1m:[0;33;1m13[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.util.concurrent.Executors$RunnableAdapter.[0;35;1mcall[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.util.concurrent.FutureTask.[0;35;1mrun[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.SystemUtils.[0;35;1ma[0;32;1m ([0;33;1mSourceFile[0;32;1m:[0;33;1m44[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.MinecraftServer.[0;35;1mB[0;32;1m ([0;33;1mMinecraftServer.java[0;32;1m:[0;33;1m715[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.DedicatedServer.[0;35;1mB[0;32;1m ([0;33;1mDedicatedServer.java[0;32;1m:[0;33;1m374[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.MinecraftServer.[0;35;1mA[0;32;1m ([0;33;1mMinecraftServer.java[0;32;1m:[0;33;1m654[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- net.minecraft.server.v1_8_R3.MinecraftServer.[0;35;1mrun[0;32;1m ([0;33;1mMinecraftServer.java[0;32;1m:[0;33;1m557[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m[0;31;1m- java.lang.Thread.[0;35;1mrun[0;32;1m ([0;33;1mUnknown Source[0;32;1m)[m
    [10:39:55] [Server thread/INFO]: [0;33;1m[WetSponge -> [0;31;1mError[0;33;1m] [0;31;1m--------------------------------------------[m
     
  6. Could you please send the WHOLE file?
    Thanks.
     
  7. I can assure you we've been working to fix all the bugs before adding new functions, it's just that as the progress between WetSponge and EggWars right now are very related, we have to implement some new functions in EggWars to know if something in WetSponge is working right or not (like the villagers system or the async arena saving on spigot, which although right now it works, it's not as fast as it should).

    We are ultimating the latest fixes right now hand by hand with @friishon, who is helping us to test every little thing on the plugin ^^
     
    • Like Like x 1
  8. can you send all latest log file? but send the file, not the error, send all the file please upload the lastest.log please
     
  9. Degoos updated [XMas%Disc][WetSponge] EggWars - MultiArena & Bungee, MultiLang, Fully Customizable with a new update entry:

    New update!

    Read the rest of this update entry...
     
  10. Degoos updated [WetSponge] EggWars - MultiArena & Bungee, MultiLang, Fully Customizable with a new update entry:

    New update! Official update!

    Read the rest of this update entry...
     
  11. @Degoos

    Hi, I want to report a bug.

    I am using MultiverseInventories, when I enter an arena I do not get the item "Selector", and when I leave I have it in the inventory.

    They are different worlds.
     
  12. Hi! That's a MultiverseInventories error. We've tried to add support to Multiverse plugins, but it seems they break all the world system.
     
  13. So I guess you can not do anything about it? With the previous EggWars plugin there was no problem, although I imagine that the code does not look anything like the previous one.

    Putting the world of arena in the same group as the main world, it already gives the items correctly, but when the game ends, the user takes the objects.

    If I changed multiverseinventories for perworldinventory would it work?
    https://www.spigotmc.org/resources/per-world-inventory.4482/

    And a question, an object will be added to the inventory to exit the arena (without having to write /ew leave)?
     
    #96 Seru, Jan 22, 2018
    Last edited: Jan 22, 2018
  14. I have an error:
    [WetSponge -> Error] --------------------------------------------
    [WetSponge -> Error] An error has occurred while WetSponge was parsing the event Spigot-PlayerCommandPreprocessEvent!
    [WetSponge -> Error]
    [WetSponge -> Error] Type: java.lang.NullPointerException
    [WetSponge -> Error]
    [WetSponge -> Error] Description: -
    [WetSponge -> Error] Cause: -
    [WetSponge -> Error]
    [WetSponge -> Error] StackTrace:
    [WetSponge -> Error] - java.util.Optional.orElseThrow (Unknown Source)
    [WetSponge -> Error] - com.degoos.eggwars.command.GeneralCommand.executeCommand (GeneralCommand.java:51)
    [WetSponge -> Error] - com.degoos.wetsponge.listener.spigot.SpigotSendCommandListener.lambda$onCommand$0 (SpigotSendCommandListener.java:45)
    [WetSponge -> Error] - java.util.Optional.ifPresent (Unknown Source)
    [WetSponge -> Error] - com.degoos.wetsponge.listener.spigot.SpigotSendCommandListener.onCommand (SpigotSendCommandListener.java:42)
    [WetSponge -> Error] - sun.reflect.NativeMethodAccessorImpl.invoke0 (Native method)
    [WetSponge -> Error] - sun.reflect.NativeMethodAccessorImpl.invoke (Unknown Source)
    [WetSponge -> Error] - sun.reflect.DelegatingMethodAccessorImpl.invoke (Unknown Source)
    [WetSponge -> Error] - java.lang.reflect.Method.invoke (Unknown Source)
    [WetSponge -> Error] - org.bukkit.plugin.java.JavaPluginLoader$1.execute (JavaPluginLoader.java:302)
    [WetSponge -> Error] - org.bukkit.plugin.RegisteredListener.callEvent (RegisteredListener.java:62)
    [WetSponge -> Error] - org.bukkit.plugin.SimplePluginManager.fireEvent (SimplePluginManager.java:502)
    [WetSponge -> Error] - org.bukkit.plugin.SimplePluginManager.callEvent (SimplePluginManager.java:487)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.PlayerConnection.handleCommand (PlayerConnection.java:1346)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.PlayerConnection.a (PlayerConnection.java:1189)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.PacketPlayInChat.a (PacketPlayInChat.java:45)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.PacketPlayInChat.a (PacketPlayInChat.java:1)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.PlayerConnectionUtils$1.run (SourceFile:13)
    [WetSponge -> Error] - java.util.concurrent.Executors$RunnableAdapter.call (Unknown Source)
    [WetSponge -> Error] - java.util.concurrent.FutureTask.run (Unknown Source)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.SystemUtils.a (SourceFile:46)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.MinecraftServer.D (MinecraftServer.java:747)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.DedicatedServer.D (DedicatedServer.java:399)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.MinecraftServer.C (MinecraftServer.java:678)
    [WetSponge -> Error] - net.minecraft.server.v1_11_R1.MinecraftServer.run (MinecraftServer.java:576)
    [WetSponge -> Error] - java.lang.Thread.run (Unknown Source)
    [WetSponge -> Error] --------------------------------------------
     
  15. You must have the plugin bought if you want the plugin working! ;)
     
  16. Your example config link is broken in the description.

    Can I change it so that players don't protect a dragon egg, but another block of my choosing?