/spawn keeps breaking

Discussion in 'Community Feedback and Suggestions' started by centaris, Feb 20, 2020.

  1. I am running a server but /spawn keeps breaking and other tp commands as well. When you do /spawn, nothing happens. However,
    - rebooting the server - it works for a bit.
    - /ess reload - it works
    - Only people that aren't opped cant, Me (owner of server) I can
    - All Essentials plugins are the latest

    Please someone find a fix for me!

    Here are my plugins: Plugins (58): CleanroomGenerator, NoIGPoppyDrop, BucketStacker, PlaceholderAPI, PlugMan, TagsGUI, ViaVersion, dynmap, WorldEdit, BroadcastXS, Essentials_WarpGUI, NoRain, ClearLag, Votifier, Multiverse-Core, ProtocolLib, GuiRedeemMCMMO, PhantomAntiDupe, NoHopper, ObsidianBreaker, WorldEditCrashFix, PermissionsEx, NightVisionReloaded, AntiDisconnectSpam, mcMMO, StaffChat, Vault, Scoreboard-revision, MoneyPouch, WorldGuard, Holograms, Vote, AuctionHouse, MobStacker, RandomTeleport, PlayerVaults, ClickWarp, ShopGUIPlus, Essentials, Jobs, EnchantGui, Citizens, EssentialsChat, SuperVanish, AntiSwear, EnjinMinecraftPlugin, CrazyCrates, LeaderHeadsRevamped, Factions, TabList, CommandNPC, EssentialsSpawn, GenBucket, CompatNoCheatPlus, SilkSpawners, NoCheatPlus, ChunkBuster, NoPoppyDrops
     
  2. This is not the place to ask this.

    The answer is to add them the permission for the command.
     
  3. Already added. Nothing happens when you do /spawn
     
  4. Maybe RandomTeleport or one of the Warp Plugins is the problem.

    Are there any bugs in the console?
     
  5. No, you just /tp then it says "commencing in 3 seconds.." then nothing happens
     
  6. Which plugin is it?
     
  7. EssentialsX
     
  8. Try to remove all plugins and add one after another. Try the /tp command after each plugin. Maybe this will help
     
  9. Possibly try to get a dedicated /spawn plugin. It could be something with conflicting plugins. Are there any errors in the console when the server restarts? If there are, could you please share them?

    If you haven't done too much with Essentials, try re-downloading the plugin. If you don't want to re-download the plugin, try scanning through the files and trying to spot an error.
     
  10. do they have permission?
     
  11. Try restarting server, updating plugins, resetting spawn (and world spawn), and check if all your plugins are compatible (or are fighting eachother for the /spawn command)