Spawners won't spawn

Discussion in 'Spigot Help' started by phospholipid, Feb 14, 2015.

  1. I have what strikes me as a problem that I'm sure has a simple fix; I just can't find that fix.

    I have a small friends-only server and when I place spawners into my dungeons, they don't do anything. They don't produce monsters. They don't even spin. They just sit there, starting at me.

    I have Worldguard/WorldEdit, Treasurechest, and a permissions plugin. I've been through config files and don't see anything obvious to me that would allow or disallow spawners to operate. The world does product monsters when it normally would (darkness, etc.). So, what am I doing wrong?
     
  2. Don't even spin? Very strange. Never heard of that...
     
  3. Right!?!

    It's crazy weird.
     
  4. The linked video shows what happens when I place the spawner.

     
  5. Do /give (player) spawner 1 or /i spawner 1 and try placing it that way.
     
    • Informative Informative x 1
  6. That absolutely did the trick. Thanks. I used the syntax: /give {player} minecraft:mob_spawner 1

    Thanks a bunch. As a bonus, can anybody point me in the direction of anything that will allow me to change spawner behaviors, like spawn rate, etc.

    Thanks!
     
  7. Do you have clearlagg?
     
  8. No. I don't have that plugin. Should I?
     
  9. Not unless your having lag issues, severe lag issues which you shouldn't be on a small server. Looks like you figured out a fix, but stay away from Clearlagg unless your server starts to severely lag.
     
    • Informative Informative x 1