Spigot SpawnTP 4.0.0

Teleports joined player to set spawn location. Ideal for hub servers!

  1. Luukth submitted a new resource:

    SpawnTP - Teleports joined player to set spawn location. Ideal for hub servers!

    Read more about this resource...
  2. Luukth updated SpawnTP with a new update entry:

    per world spawn \\ tp to spawn on world change \\ added /spawn command

    Read the rest of this update entry...
  3. I can confirm it doesn't work in 1.9
    Code (Text):
    [21:03:32] [Server thread/INFO]: MrEMan issued server command: /spawntp setspawn
    [21:03:32] [Server thread/ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'spawntp' in plugin Spawntp v1.0.0
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at org.bukkit.craftbukkit.v1_9_R1.CraftServer.dispatchCommand(CraftServer.java:645) ~[spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.PlayerConnection.handleCommand(PlayerConnection.java:1342) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.PlayerConnection.a(PlayerConnection.java:1177) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_74]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_74]
    at net.minecraft.server.v1_9_R1.SystemUtils.a(SourceFile:45) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.MinecraftServer.D(MinecraftServer.java:721) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.DedicatedServer.D(DedicatedServer.java:400) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.MinecraftServer.C(MinecraftServer.java:660) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at net.minecraft.server.v1_9_R1.MinecraftServer.run(MinecraftServer.java:559) [spigot.jar:git-Spigot-6f291ea-0c7ae56]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_74]
    Caused by: java.lang.NullPointerException
    at me.Luukth.Main.Main.onCommand(Main.java:90) ~[?:?]
    at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot.jar:git-Spigot-6f291ea-0c7ae56]
    ... 15 more
    I hope you get time to update this.
  4. I see. I was planning to work on it this week. Since it is a really basic plugin I should be able to fix it rather quickly.

    Thank you for your message.
  5. Luukth updated SpawnTP with a new update entry:

    1.9 support + bug fixes

    Read the rest of this update entry...
  6. I posted a resource update. If this does not fix your problem please remove the config and let the plugin generate a new one. It is mostly an error with an spawnlocation that has not been set. Please contact me if you need more help.
  7. @Luukth Can u add my network TheCoreMC.fmc.pw
  8. Please send me a private message. Thank you
  9. It won't work on 1.9. The config won't generate and the plugin won't show up in the /plugin list.
  10. I have tested it with the latest version of spigot. Wich version are you running? Also what java version are you using, and does the plugin give any errors?
  11. I am using Java 7.
    And I am running on 1.9.2. (it says 11 versions behind for me)
  12. Luukth updated SpawnTP with a new update entry:

    Compiled with latest Spigot version

    Read the rest of this update entry...
  13. Then java 7 could be the problem.
    I have made a resource update. Can you check if the plugin works now?
  14. Still doesn't work.
    Now the config generates and it loads up but when I set my spawn it won't teleport me when I join.
  15. Could you maybe send me your config.yml?
  16. My Config:
    onWorldChange: 'true'
    SpawnCommand: 'false'
    world: world , -1438.5483618514459 , 21.0 , 2059.4725414137265 , -0.44999897 , -0.44963476
  17. Yes, you need to set SpawnCommand from false to true. Otherwise the spawn command does not work.
  18. I don't want them to use /spawn because I use this on my HUB. I only want them to teleport to the world spawn when they join the server.
  19. That should work. No need to change the settings. Only /spawntp setspawn schould do the trick.
  20. I did that and it still won't work.