Spigot 1.13 not working

Discussion in 'Spigot Help' started by peh, Jul 28, 2018.

  1. peh

    peh

    I just installed Spigot 1.13 Completely fresh on a Ubtuntu 18 VPS.

    The VPS has all the correct stuff installed
    It was a fresh spigot install

    The server starts up fine but whenever I try and connect i get the "Authentication servers are down. Please try again later"

    This only happens with Spigot 1.13. I tried Spigot 1.12.2 and it worked perfectly fine.
     
  2. where are you getting your spigot 1.13 jar file?
     
  3. peh

    peh

    Hope I'm allowed to post this link here

    Link removed
     
    #3 peh, Jul 28, 2018
    Last edited by a moderator: Jul 28, 2018
  4. well try download an official version of spigot using Build Tools, as that website and jar file is not supported on this website due to the fact its technically an illegal build

    Its been proven in the past that those jar files are potentially unsafe, and cause a lot of issues
     
  5. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Not a Spigot issue.
     
  6. peh

    peh

    Tried that just now, also does not work.

    upload_2018-7-28_23-13-9.png
     
  7. Hm... that is very odd. I just started up a BuildTools to test it, and it works perfectly fine. Ive also never done it on Linux so im not quite sure
     
  8. maybe try run build tools on your computer itself, then upload spigot to your VPS
     
  9. peh

    peh

    It's just odd Spigot 1.12.2 works but 1.13 doesn't

    I'm not running a Linux PC so I don't think I can't run it on my pc then upload
     
  10. it wouldn't matter, its just building the jar file.
     
  11. ALSO.. for build tools (linux) did you follow the proper steps? Including:
    1. On Linux run git config --global --unset core.autocrlf, then run java -jar BuildTools.jar in bash or another appropriate shell.
     
  12. peh

    peh

    I did do that, it didn't work still.

    I tried building build tool on windows... it also did not work

    upload_2018-7-28_23-29-35.png

    Do you think you could just build me a 1.13 jar and send me it on discord? XD Getting desperate now
     
  13. electronicboy

    IRC Staff

    That message looks like you've either got another copy of BT running or you're getting hit with a windows issue; Basically, don't run your server or any program on the desktop if you've got onedrive installed, heck; don't do it anyways, the desktop is the completely wrong place for that
     
  14. peh

    peh

    I've never used BT before.

    I tried running it on Linux and Windows. Neither work. I'm trying to run it on a Ubuntu web server not my desktop

    Trying everything hoping something works :/
     
  15. That is odd you're having so much trouble with build tools, I have never once had an issue with running build tools on either of my computers (windows and mac)
    Shoot me a message on discord Ill send you a jar I just built
    Just click my little Skript Discord button bellow
     
  16. I recommend using a subfolder of the Downloads folder. It is not synced.
     
  17. electronicboy

    IRC Staff

    I mean your desktop, asin the desktop folder; and that screenshot you last posted is running on a windows machine, in the desktop folder
     
  18. Not sure if this may help you but for some reason I needed a completely empty folder for BuildTools to run and create 1.13 files, if I tried using a folder with even one other folder or file, it just would not build at all.