[Spigot 1.14.4] Server constantly crashing for months

Discussion in 'Spigot Help' started by YJJcoolcool, Mar 29, 2020.

  1. Hi, I have been running a Spigot 1.14.4 server for quite some time now, but recently over the past few months, the server has started crashing frequently just a couple of hours after I start it.
    Until now, I still do not understand what is causing the server to crash.
    Just for your info, the server has 8GB of RAM. (Which is quite a lot considering it's running normal Minecraft without any mods and not a lot of plugins compared to other servers)

    For the past couple of months I have searched online for solutions, most of them didn't work. For those that "worked", the server started crashing again after several hours.

    Here's the list of Plugins running on the server:
    CoreProtect, dynmap, WorldEdit, ColoredSigns, FlySpeed, Multiverse-Core, WorldGuard, AudioConnect, AutoRestart, ImageOnMap, PermissionsEx, RFChairs, Elevators_v2, Vault, GWarp, RealTime, SimpleSit, Essentials, BKCommonLib, SignLink, CustomHeads, DiscordSRV, Train_Carts, EssentialsChat, TCHangRail

    Here is what I tried out:
    - I deleted the session.lock file. I read from one forum. Didn't work.
    - I repaired the world file using some python code. The server didn't crash for a few days. I thought it was all over, until it started crashing again.
    - I tried lowering the view-distance in the config file from 10 to 8. Nothing seems to have changed.
    - I tried using Timings to see whether a plugin is lagging the server. Nothing out of the ordinary. Here is today's timings: https://timings.spigotmc.org/?url=gefeteduci
    - TrainCarts is usually the most server intensive plugin. I tried letting the server run for a few days. It crashed one time yesterday, two times today.

    Other things to note:
    - Some people say it's just the fact that 1.14.4 is unstable. Changing the server version is a big thing that cannot be reversed to I'd rather stay at the same version.
    - The server frequently puts out "Can't keep up! Is the server overloaded?"
    - And in the past few days, it's beginning to put out "Something's taking too long! 'root.tick.save' took aprox. ... ms" along with root.tick and root itself.

    Here is the latest server thread dump from today:
    https://pastebin.com/SYjCB16n