Spigot 1.17.1 start.bat online problem

Discussion in 'Spigot Help' started by Lars2511, Jul 10, 2021.

  1. (Sorry for bad english)
    So, i have a problem.
    I host a small server of an second PC and i wanted to update it from 1.16.5 to 1.17.1.
    Befor the Update everything worked fine. I used my start.bat file to start the server and updated my Java version, after the server told me to do. However when i start my server now with the .bat file i wont get any error, but its not online any more (yes i opened the ports and they are still open). When i start the server with the spigot-1.17.1.jar file everything works perfectly and i can acces the server from other Computers and Networks. Only when i want to start the server with the .bat file to get more RAM its not listed as online and i cant acces it.
    I have no clue why its not working.
    For the start.bat file i used the arguments from here:
    https://www.spigotmc.org/wiki/spigot-installation/#wikiPage
    I hope someone can help me.
     
  2. Post here please:
    1. bat file (recommended) or atleast command line from bat, where your start spigot.
    2. results of command: "java -version". (insert it in your batch file before starting spigot)
    3. any outputs in console while your batch file starting spigot. Add -nogui so as not to confuse the console with the server gui. Also add "pause" at the end of your batch file to make pause and see all console outputs.

    PS: If you use several java version on your server, then try to insert "set PATH=<path to the right version of java bin folder>;%PATH% " at the start of your batch file.
     
    • Like Like x 1
  3. Strahan

    Benefactor

    Did you perhaps make a program rule for your firewall? If so, when you double click the jar it runs javaw.exe but when you run it in a batch you typically use java.exe so the rule wouldn't take effect. I try not to use program rules, I prefer just making port rules.

    That'll work, but ideally they should either properly fix the path (sysdm.cpl, Advanced, Environment Variables) or just put a fully qualified path to the executable in the batch file.
     
  4. Hey,
    thanks for the replie.
    1.I'll add the .bat file to my replie. (changed a copy of it to .txt, so I can upload it here)
    2.
    java version "16.0.1" 2021-04-20
    Java(TM) SE Runtime Environment (build 16.0.1+9-24)
    Java HotSpot(TM) 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing)
    3. I only get normal outputs, like always. I had already added nogui and pause.

    I'll try to set the path with the argument.
     

    Attached Files:

  5. Hi,
    thanks for the replie.
    I didn't made any program rules. Its a little PC I recently baught new. I had only the server running on it perfectly, until now.
    So if I would start the server with javaw.exe it will work?
     
  6. Strahan

    Benefactor

    Well, if it wasn't a program rule then it shouldn't matter. I assume you made a port rule then, right? If you aren't sure, hit start and type command and right click command prompt and choose run as administrator. When that opens, paste this in:
    Code (Text):
    netsh advfirewall firewall add rule name="Minecraft Server" dir=in action=allow protocol=TCP localport=25565
    Hit enter, and it should say "Ok." Then try again.
     
    • Like Like x 1
  7. Hi, thanks.
    I'll try it later and inform you, if it worked.
     
  8. Yes, i made an port rule, via the interfacer of my rooter.
     
  9. Hi guys,
    i tried this
    and it said "Ok." but it didnt fixed the problem.
    Instead i fixed it otherwise. I used this:
    I edited the .bat file to this:
    Code (Text):
    @echo off
    "C:\Program Files\Java\jdk-16.0.1\bin\javaw.exe" -Xmx4096M -Xms4096M -jar spigot-1.17.1.jar
    pause
    Now it works fine.

    Thanks for helping (y)
     
    • Like Like x 1
  10. Strahan

    Benefactor

    Glad it works. Weird though; the port rule should authorize any program for 25565. Well, so long as it works :)
     
  11. Good evening,

    I got the same problem on linux debian. But the server isn't making any log...
    Does anyone have an idea?
     
  12. Might be that on the first time, the windows firewall had a gui pop up to allow it already or its base settings are different.

    Clearly the problem here was that the old java installation was still used.
     
  13. I'm not using Windows. Like I said im using Linux Debian and their isn't any need to allow...
    I also used Java 16 on Linux, but Version 1.17.1 still not working at all, but 1.16.5 is working without any problems on Java 8 and 16...
    So this doesn't solve my problem...

    Anyone else have an idea?