Spigot 1.7 ERROR with Bungecoord 1.12

Discussion in 'Spigot Discussion' started by KSDpolska, Apr 1, 2018.

  1. Hello!
    There is an error with Bungecoord (1.12) and my server Spigot 1.7.
    When a User with 1.8 Forge joins to the sv, All users 1.7 that are in his field of view are kicked from the sv giving me this error:

    [Netty IO #2/WARN]: net.minecraft.util.io.netty.handler.codec.EncoderException: java.lang.NullPointerException [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.handler.codec.MessageToByteEncoder.write(MessageToByteEncoder.java:129) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.DefaultChannelHandlerContext.invokeWrite(DefaultChannelHandlerContext.java:644) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.DefaultChannelHandlerContext.write(DefaultChannelHandlerContext.java:698) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.DefaultChannelHandlerContext.writeAndFlush(DefaultChannelHandlerContext.java:688) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.DefaultChannelHandlerContext.writeAndFlush(DefaultChannelHandlerContext.java:717) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.DefaultChannelPipeline.writeAndFlush(DefaultChannelPipeline.java:893) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.AbstractChannel.writeAndFlush(AbstractChannel.java:239) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.server.v1_7_R4.QueuedProtocolSwitch.run(SourceFile:143) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:354) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:348) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.util.concurrent.SingleThreadEventExecutor$2.run(SingleThreadEventExecutor.java:101) [16:51:39] [Netty IO #2/WARN]: at java.lang.Thread.run(Unknown Source) [16:51:39] [Netty IO #2/WARN]: Caused by: java.lang.NullPointerException [16:51:39] [Netty IO #2/WARN]: at net.minecraft.server.v1_7_R4.PacketDataSerializer.a(PacketDataSerializer.java:269) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.server.v1_7_R4.PacketPlayOutNamedEntitySpawn.b(PacketPlayOutNamedEntitySpawn.java:82) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.server.v1_7_R4.PacketEncoder.a(PacketEncoder.java:37) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.server.v1_7_R4.PacketEncoder.encode(PacketEncoder.java:43) [16:51:39] [Netty IO #2/WARN]: at net.minecraft.util.io.netty.handler.codec.MessageToByteEncoder.write(MessageToByteEncoder.java:111) [16:51:39] [Netty IO #2/WARN]: ... 11 more [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException [16:51:39] [Netty IO #2/WARN]: java.nio.channels.ClosedChannelException

    Please help me.
    Thanks in advanse.
     
  2. 1.7 was before the username change system was made, therefore they are incompatible and that is likely what is throwing the errors.
     
  3. and can I do something to fix this error because I have to use 1.7
     
  4. Don't allow 1.8 and 1.7 users onto the same server. with bungee you can proxy versions to different servers.
     
  5. But, it is a HCF server, so I can't separate both versions in different server, Is there any other way?
     
  6. I don't believe there is. As far as I know 1.7 and 1.8+ are completely incompatible with each other. you either have to deal with the errors, or create a server for 1.8+ and a server for 1.7-
     
  7. But It only happens when the user is 1.7 FORGE, not with 1.7 VANILLA.
     
  8. Bukkit/Spigot can't read whether or not a user is modded
     
  9. Really? So, Why happens this error only with FORGE ussers?
     
  10. No, that's v1_7_R4 which is the package version of 1.7.10 which was after the new system was introduced.
    That doesn't make sense since the error only occurs with Forge clients.

    Anyway, sounds like a bug to me - and legacy versions are not supported.
     
    • Informative Informative x 1
  11. So... Is there any way to fix this bug?
     
  12. Sure. It's either a BungeeCord, Forge or maybe a CraftBukkit error. But provided that you're running the latest possible version of each software, you'll need to get a developer to fix it privately. If it's only fixable by modifying Forge, then there's nothing at all you can do since you won't get every single client to install it. Maybe, there are options to dodge it by changing the setup without changing the software itself, but I cannot help you with that.

    [​IMG]
     
    • Like Like x 2