Spigot 1.8.7 Console does not showing up! Is that normal?

Discussion in 'Spigot Help' started by Matz, Jul 8, 2015.

  1. Hello, i've a problem with 1.8.7 spigot server, just downloaded and tried running a few minutes ago.
    When i run the java executable, the console is not showing up.. is that normal? I don't think so.. this is my log:

    [01:12:23] [Server thread/INFO]: Starting minecraft server version 1.8.7
    [01:12:23] [Server console handler/ERROR]: Exception handling console input
    java.io.IOException: Handle non valido
    at java.io.FileInputStream.readBytes(Native Method) ~[?:1.8.0_45]
    at java.io.FileInputStream.read(Unknown Source) ~[?:1.8.0_45]
    at java.io.BufferedInputStream.fill(Unknown Source) ~[?:1.8.0_45]
    at java.io.BufferedInputStream.read(Unknown Source) ~[?:1.8.0_45]
    at org.bukkit.craftbukkit.libs.jline.internal.NonBlockingInputStream.read(NonBlockingInputStream.java:248) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:261) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.internal.InputStreamReader.read(InputStreamReader.java:198) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(ConsoleReader.java:2145) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLineSimple(ConsoleReader.java:3183) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2333) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2269) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(ConsoleReader.java:2257) ~[craftbukkit.jar:git-Bukkit-e91aed8]
    at net.minecraft.server.v1_8_R3.DedicatedServer$2.run(DedicatedServer.java:80) [craftbukkit.jar:git-Bukkit-e91aed8]
    [01:12:23] [Server thread/WARN]: To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
    [01:12:23] [Server thread/INFO]: Loading properties
    [01:12:23] [Server thread/INFO]: Default game type: SURVIVAL
    [01:12:23] [Server thread/INFO]: Generating keypair
    [01:12:23] [Server thread/INFO]: Starting Minecraft server on *:25565
    [01:12:23] [Server thread/INFO]: Using default channel type
    [01:12:23] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-e91aed8 (MC: 1.8.7) (Implementing API version 1.8.7-R0.1-SNAPSHOT)
    [01:12:24] [Server thread/INFO]: Preparing level "world"
    [01:12:24] [Server thread/INFO]: Preparing start region for level 0 (Seed: -7646563555424969753)
    [01:12:25] [Server thread/INFO]: Preparing start region for level 1 (Seed: -7646563555424969753)
    [01:12:26] [Server thread/INFO]: Preparing start region for level 2 (Seed: -7646563555424969753)
    [01:12:26] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [01:12:26] [Server thread/INFO]: Done (2,211s)! For help, type "help" or "?"

    Thanks for your help! (i also updated java, with no results)
     
  2. You didn't left click the jar file did you..?
     
  3. yes.. i did. first time with this things guys.. be patient ahah
     
  4. Okay, Make sure you're starting the server with a batch file or script. Otherwise you won't be able to view the console. If you need an example I'm sure Google has lots :).
     
  5. ok i found the solution in installation guide.. solved
     
  6. thanks bro.. :)